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1 Software Interface 
Through this part, you can quickly know the layout of the main interface for NcStudio V15 
Laser Cutting CNC System. 

The main interface is as follows: 

 

1. Menu bar 
2. Common toolbar 
3. Control bar display button 
4. Machine control bar 
5. Layer toolbar 
6. Statistics bar 
7. Alarm/system info bar 
8. Drawing information bar 
9. Drawing window 
10. Drawing toolbar 

1.1 Common Toolbar 
It is used to show the following frequently used instructions: 

  New: to create a new toolpath file. 

  Import: to import a DXF / DWG / PLT / G / NC file. 

  Open: to open a NCEX file. 

  Save: to save a toolpath file as a NCEX file. 
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  Undo: to go back to a previous state by reversing the effects of one or more 
commands. 

  Redo: to do over again. 

  Show order: to show the machining order. 

  Show direction: to show the machining direction. 

  Highlight unclosed objects: to mark all unclosed objects with red color. 

  Clear trace: to clear the machining trace. 

  Catch: to enable catching function. 

  Catch options: to set options for catching. 

  Select: to select all objects, deselect selected objects, cancel selected objects, 
and select unclosed objects, tiny objects, inner objects, outer objects and similar 
objects. See Select Objects for details. 

  Transform: to translate objects, rotate objects, vertically or horizontally mirror 
objects. See Translate Objects, Rotate an Object and Mirror Objects for details. 

  Clear: to clear some set technics. See Do Clearing for details. 

  Merge: to combine several objects as one object. See Merge Objects for 
details. 

  Explode: to trim the toolpath. See Explode Objects for details. 

  Smooth curve: to make polylines flat and even. See Smooth Curves for details. 

  Group objects: to bind several objects as a group. See Group Objects for 
details. 

  Ungroup objects: to separate the grouped objects. See Ungroup Objects for 
details. 

  Preprocess: to preprocess several target objects with one click. See 
Preprocess with One Click for details. 

  Lead line: to set a lead-in and lead-out lines. See Set a Lead Line for details. 

  Start point: with a lead line: to set the start point of the lead line; with no lead 
lines: to set the current point as the start point. 

  Micro joint: to reserve the set distance without machining and connect the 
workpiece and sheet. See Execute Micro Joint for details. 

  Unfill / fill: to set unfill (reserve the outer part) or fill (reserve the inner part). 
See Set Fill or Unfill for details. 

  Mach direction: to show and modify the machining direction. See Change the 
Machining Direction for details. 

  Bridge: to connect two objects with a bridge. See Bridge Objects for details. 
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  Compensate: to compensate the kerf in the actual machining. See Set Kerf 
Compensation for details. 

  Chamfer: to add a chamfer. See Add a Chamfer for details. 

  Sort machining order: to show and modify the machining order. See Change 
the Machining Order for details. 

  Scan cut: to replan the toolpath to find the most efficient path for machining, so 
as to avoid unnecessary tool lifting and feeding and improve machining efficiency. 
See Set Scan Cutting for details. 

  Instant setting: to set fill/unfill, lead lines, machining direction, machining order 
and kerf compensation with one click. See Execute Instant Setting for details. 

  Nest: to do nesting to improve sheet utilization and machining efficiency. See 
Nest for details. 

  Array: to copy machining objects according to the set arraying way. See 
Execute Array for details 

  Set berth: to open Set Berth Point dialog box. See Set the Workpiece Origin 
for details. 

  Follow: to calibrate the cutting head. See Calibrate Capacitance for details. 

  Common param: to set frequently used parameters, including machine 
parameters, following-up parameters and units. See Set Common Parameters for 
details. 

1.2 Control Bar Display Button 
You can show/hide the machine control bar by clicking CNC Control in the upper right 
corner. 

1.3 Machine Control Bar 
It includes the following: 

 Axis coordinate display bar 

 Manual control bar 

 Machining control bar 

 Machining selection bar 
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1.3.1 Axis Coordinate Display Bar 
It is shown as follows: 

 

After returning to the machine origin, sign  appears in front of each axis. 

In this bar, you can do the following: 

 To switch between workpiece coordinates and machine coordinates, click . 

 To separately set low speed, rapid speed and step size for X/Y-axis and Z-axis, 

click , and set them in Manual Speed Setting dialog box: 
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1.3.2 Manual Control Bar 
It is shown as follows: 

 

1. Axis direction buttons: to move each axis towards positive or negative direction. 
2. Simulation speed: to adjust the simulation speed, select one of the following: 

o Drag the slider. 
o Click the slider and press PgUp / PgDn or ↑ / ↓ / ← / → on the keyboard. 

3. Movement control button: to control the machine tool to move backwards (Bwd 
button) / move forwards (Fwd button) along the toolpath: 

o In Jog mode, click and hold the button. The machine tool keeps moving until 
you release it. 

o In Step mode, click the button. The machine tool only moves the set step 
size. 

4. Feed mode buttons 
o Jog mode (default mode): in this mode, click and hold an axis direction 

button or several axis direction buttons. The clicked axis/axes move(s) at jog 
speed until you release the button(s). 
In this mode, click Rapid, click and hold an axis direction button or several 
axis direction buttons. The clicked axis/axes move(s) at rapid jog speed until 
you release the button(s). 

o Step mode: in this mode, click an axis direction button. The clicked axis 
moves the customized step size (default: 5mm). 

In this mode, to customize the step size, click  in the axis coordinate 
display bar. 

Note: Please do not click an axis direction button too frequently because the 
system needs a certain time to respond. 
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1.3.3 Machining Control Bar 
It includes the following: 

 : to start machining from the beginning of the toolpath file. 

 : to stop machining. 

 : to resume machining from the exact interrupted position when the 
power interruption or E-stop occurs and the machine coordinate is correct. 

 : to execute simulation to check the toolpath in real-time. 

 : to run the machine tool without turning on related ports of laser and 
machining. There is no actual machining. 

 : to set the workpiece origin. 

 : to control the cutting head to return to the workpiece origin. 

 : to return all axes to the machine origin. 

 : to return Z-axis to the machine origin. 
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 : to calibrate the cutting head. 

 : to confirm the machining range by running the system along the frame 
of the toolpath. 

 : to do commissioning for the follow-up control system. 

 : to turn on the laser power before machining. 

 : to manually turn on laser shutter. 
To eject laser light, first, turn on the laser shutter; then, turn on the laser. 

 : to turn on/off the laser. When machining starts, the system will 
automatically turn on the laser. 

 : to manually turn on the red light, which is used as a kind of guide light 
to guide the laser position on the sheet. 

 : to turn on the laser for a certain time. The system will automatically 
turn on the laser for the set burst time and turn it off. 

 : to blow air. When machining starts, the button will be highlighted, and 
the system will automatically turn on the blowing valve and blow air. 
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 : to blow oxygen. When machining starts, the button will be highlighted, 
and the system will automatically turn on the blowing valve and blow oxygen. 

 : to blow nitrogen. When machining starts, the button will be highlighted, 
and the system will automatically turn on the blowing valve and blow nitrogen. 

 : to set automatic nozzle cleaning. See Set Nozzle Cleaning for details. 

 : to turn on lube. 

 : to automatically exchange the workbench, so as to improve machining 
efficiency. 

 : to release the workbench during manually exchanging the workbench. 

 : to control the upper workbench entering the machining area, so as to 
improve machining efficiency. 

 : to control the lower workbench entering the machining area, so as to 
improve machining efficiency. 

 : to turn on the fan. The system will control whether to automatically turn 
on the fan when machining starts and turn off fan when machining ends through 
system parameters Fan On at Machining Start and Fan Off at Machining End. 
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1.3.4 Machining Selection Bar 
You can check the following in the bar: 

 Cut Selected: with it checked, the system will only execute machining, dry run, 
simulation, frame cutting and breakpoint resume for the selected objects. 

 Jog Cut: with it checked, the laser will keep on during manually moving the axis for 
a certain distance. After jog cutting ends, the checking status will be canceled by 
default, and the laser will not be automatically turned on during the next machining. 

 Find Edge before Start: with it checked, the system will automatically find edges of 
the sheet before machining. 

1.4 Layer Toolbar 
You can do the following operations related to layer: 

 : to open Layer dialog box. See Layer Interface for details. 

 : to include the selected object(s) during machining. 

 : to exclude the selected object(s) during machining. At this time, the object(s) 
turn(s) to white. 

 : to convert the color of the selected objects into the color of 
the selected layer. 

1.5 Statistics Bar 
It is shown as follows: 

 
You can do the following in the bar: 

 Open Statistic Information dialog box by clicking Report. See Check Statistics for 
details. 

 Open Count Setting dialog box by clicking Count Setting. See Count Machining 
for details. 

 Check the machining time, current layer, machining count, system status and 
machining speed. 
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1.6 Alarm/System Info Bar 
It is shown as follows: 

 
You can do the following in the bar: 

 Open Log dialog box by double clicking Alarm / System. See Check System Logs 
for details. 

 Troubleshoot the alarm or check the log details by double clicking the related alarm 
item or system information item. 

1.7 Drawing Information Bar 
It is shown as follows: 

 

You can check the following in the bar: 

 Scaling of the drawing window 

 Tuning distance 

 Information of current drawing objects, including drawing steps and meaning, step 
result, etc. 

1.8 Drawing Window 
You can draw and preview objects in this window. 

1.9 Drawing Toolbar 
You can do the following in the toolbar: 

 Draw objects 

 Execute auxiliary editing 
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2 Quick Start 
2.1 Overview 
Through this part, you can quickly know the basic machining process of NcStudio-V15 
Laser Cutting CNC Control System and start machining sheets. 

The process is as follows: 

 

2.2 Execute Returning to the Machine Origin or Set Datum 
It differs in the encoder type: 

 Incremental encoder: execute returning to the machine origin 

 Absolute encoder: set datum 
You can set parameter Encoder Type in System Parameters dialog box. 

2.2.1 Execute Returning to the Machine Origin 
The origin of the machine coordinate system, also called mechanical origin or home, is a 
fixed point assigned by designing, manufacturing and debugging before the machine tool 
leaves the factory. 
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It is used to synchronize the machine coordinate system of the system with that of the 
machine tool. 

Before executing returning to the machine origin, make sure all servo alarms have been 
removed. 

To execute returning to the machine origin, do the following: 

1. In the menu bar, click Machining → Go Home → Go Home Setting. Go Homing 
dialog box pops up: 

 
The dialog box pops up after the software starts by default. If you need to cancel 
the setting, uncheck This dialog pops up automatically when software starts in 
the bottom. 
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2. Click one of the following: 
o To return all axes to the machine origin, click All Axes. Z-axis returns to the 

machine origin firstly, then X-axis and Y-axis return in sequence. 

Alternatively, click  in the machine control bar. 
o To return a single axis to the machine origin, click the button for a single axis, 

the target axis returns to the machine origin. 

To return Z-axis, alternatively, click  in the machine control bar. 
o If you make sure that the current position is the same with the machine 

coordinate, the machine tool has never been turned off, and E-stop has 
never occurred, to set the current position as the machine origin, click 
DirectSet. 

Alternatively, in the menu bar, click Machining → Go Home and select a method to return 
to the machine origin. 

After executing returning to the machine origin, sign  appears in front of each axis in the 
machine control bar. 

2.2.2 Set Datum 
With an absolute encoder, you can set the current position of the cutting head as the 
machine origin through setting datum when you use the system at the first time. 

Compared to returning to the machine origin with an incremental encoder, it owns the 
following advantages: 

 No need to set returning orders for all axes. 

 No need to set datum again after restarting the system, and recovering from power 
interruption and E-stop because the system will automatically read the datum 
information. 
Note: Please set datum again after replacing battery of the absolute encoder. 

To set datum, do the following: 

1. In the menu bar, click Machining → Set Datum. 
2. Click one of the following: 

o To set datum for all axes, click All. 
o To set datum for the target axis, click the target button. 

To cancel datum for all axes, select All(Cancel). 

After setting datum, sign  appears in front of each axis in the machine control bar. And 
after starting the software or releasing E-stop, the system automatically updates the 
machine coordinate and feedback coordinate according to feedback pulses to make the 
current machine coordinate match with the actual coordinate. 
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2.3 Calibrate Capacitance 
It is used to check the corresponding relationship of capacitance and position between the 
cutting head and the workpiece, so as to move Z-axis up and down in real time and make 
sure the relative distance between the cutting head and the workpiece is unchanged. 

To calibrate capacitance, do the following: 

1. To open Follow dialog box, do one of the following: 

o In the common toolbar, click  Follow. 
o In the menu bar, click Advanced → Follow Control. 

 

2. To eliminate zero drift caused by velocity loop controlling, click  Servo 
Calibrate. The cutting head slightly moves back and forth to compensate the error 
caused by zero drift. 

3. Select one of the following to move the cutting head to the position about 5mm far 
from the workpiece surface, and keep the workpiece still all the time: 

o If you have never calibrated capacitance, click the axis direction button, and 

click  Calibrate. 

o If you have calibrated capacitance before, click  One Key Calibrate. 
The system starts to calibrate capacitance for 20s. 

After calibrating capacitance, in Calibration Data area, check if levels of Stability and 
Smooth are above Good. 

If they are below Good, please calibrate capacitance again. 
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2.4 Load or Draw a Toolpath 
Before machining, you need to load a prepared toolpath or draw a toolpath in the drawing 
window. 

To load or draw a toolpath, do one of the following: 

 To load a toolpath, do one of the following: 
o Drag the target toolpath (supported formats: NCEX / DXF / DWG / PLT / G / 

NC) into the drawing window. 
o To open a NCEX file only, select one of the following: 

 In the common toolbar, click  Open. 
 In the menu bar, click File → Open. 

o To import a DXF / DWG / PLT / G / NC file, select one of the following: 
 In the common toolbar, to import a DXF / DWG / PLT / G / NC file, 

click  Import. 
 In the menu bar, to import a DXF / DWG file, click File → Import 

Dxf/Dwg File. 
 In the menu bar, to import a PLT file, click File → Import Plt File. 
 In the menu bar, to import a G / NC file, click File → Import G File, 

and select one of the following: 

 Import Standard G File: before importing such a file, please 
modify the file and make its format meet our requirement. 
After importing such a file, to adjust or switch the view, right 
click on the drawing window. 

 Import CAD Info in G File: to only import CAD information in 
the G file. 

Note: The file loaded by Import command will be automatically saved as a 
NCEX file. 

 To draw a toolpath, do one of the following: 
o Manually draw a toolpath in the drawing window. 

o To call an object saved in the gallery, click  Gallery in the drawing toolbar 
or click Drawing → Gallery in the menu bar, select the target object in 
Gallery dialog box, set the related parameters. The object adds into the 
drawing window. 

To insert another NCEX / DXF / DWG / PLT / G / NC file without overwriting the original 
one, in the menu bar, click File → Insert. 

After loading or drawing a toolpath, you can do the following: 

 Edit toolpaths. 

 Preprocess toolpaths. 

 Set technics. 

 Set layer. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

20 / 119 

After executing the above operations, select one of the following in the menu bar, and 
save the toolpath as a NCEX file: 

 To save all objects, select one of the following: 

o To save all objects in the default path, click  Save in the common toolbar, 
or click File → Save in the menu bar. 
The file will be put in NceFiles folder in the desktop. If such a folder does not 
exist, the system will automatically create one. 

o To save all objects in the target path, click File → Save As in the menu bar, 
and select the target path. 

 To only save the selected objects and put them into the target path, click File → 
Save Selected As in the menu bar, and select the target path. 

2.5 Set the Workpiece Origin 
The zero point of each axis in the toolpath is the workpiece origin. Before machining, you 
need to define the actual position of the workpiece origin on the sheet. 

To set the workpiece origin, do one of the following: 

 In the drawing window, drag the cross, which is at the intersection of the horizontal 
scale and vertical scale, to the target position: 

 
 Specify the position of the cutting head as the workpiece origin in the machine 

control bar: 

a. to move the cutting head to the target position, click  /  /  

/ . 

b. To set the current position as the workpiece origin, click  or press 
F5 on the keyboard. 

 To specify the coordinate of X-axis / Y-axis as the workpiece origin, in the menu bar, 
click Machining → Set Work Origin → X-axis / Y-axis. The workpiece coordinate 
of the current workpiece coordinate system turns to zero. 

 Set the workpiece origin by mouse: 

a. In the drawing toolbar, click  Set Origin Manually. The cursor turns into 

. 
b. Left click to specify the workpiece origin. 
c. To exit specifying the workpiece origin, right click. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

21 / 119 

2.6 Set Edge Finding 
It is used to calculate the rotation angle between the current sheet and the machine 
coordinate system, so as to rotate the workpiece coordinate system (WCS) in the toolpath 
based on the calculation result and establish a new WCS. 

To set edge finding, do the following: 

1. To open Edge Finding dialog box, do one of the following: 

o In the common toolbar, click  Edge Finding. 
o In the menu bar, click Machining → Edge Finding. 

2. In the lower left, set Enable Edge Finding to ON status. 
3. Select a finding mode: 

o Auto: to specify a new WCS by automatically finding three points according 
to the set berth point. 
For how to set the berth point, see Set the Berth Point for details. 

o Hand 3-point: to specify a new WCS by three points. 
o Hand 2-point: to specify a new WCS by two points. 

2.6.1 Set Automatic Edge Finding 
The origin O' of the new WCS is the berth point. And the direction of edge finding is the 
adjacent edges that close to the berth point. 

The relationship between the berth point and the direction of edge finding is as follows: 

Berth Point X-axis Direction Y-axis Direction 

Lower right Positive Negative 

Upper right Positive Positive 

Lower left Negative Negative 

Upper left Negative Positive 

Before setting automatic edge finding, make sure the berth point is at the upper right / 
lower right / upper left / lower left. 
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To set automatic edge finding, do the following: 

1. To switch to the page of automatic edge finding, in Finding Mode area of Edge 
Finding dialog box, click Auto: 

 
2. In Parameter Setting area, set parameters Sheet Size, Offset, Finding Speed 

and Follow Height. 
3. Manually move the cutting head above the sheet. 
4. Optional: If it is the first time for the system to find edges, do the following: 

a. To record the machine coordinate of the start point for edge finding, click 
Save As Start in Machine Motion area. 

b. Check Start from Finder Point in Parameter Setting area, the system 
starts to find edges from the recorded start point by default. 

5. To start to find edges automatically, click Start. The system judges the long edge 
and the short edge according to the set value of parameter Sheet Size. 

6. Optional: To return the cutting head to point O' after automatic edge finding, check 
Return to O' after edge finding. 
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The system starts to automatically find edges as follows: 

1. Locate point C: 
a. Enable the height sensing unit at the current position. 
b. Move towards the short edge at the set finding speed. The edge point is 

point C. 
2. Locate point A: 

a. Enable the height sensing unit at the position which is 20% away from the 
short edge. 

b. Move towards the long edge. The edge point is point A. 
3. Locate point B: 

a. Enable the height sensing unit at an another position which is 20% away 
from the short edge. 

b. Move towards the long edge. The edge point is point B. 

2.6.2 Set Edge Finding by Three-point 

Before setting edge finding by three-point, in the machine control bar, click  to 
guide the position. 
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To set edge finding by three-point, do the following: 

1. To switch to the page of three-point, in Finding Mode area of Edge Finding dialog 
box, click Hand 3-point: 

 
2. To specify the upper right / lower right / upper left / lower left point on the sheet as 

the origin O' of the new WCS, select a point in the drop-down box of O Pos. The 
corresponding diagram shows in Three-point area. 

3. To confirm the new WCS by specifying three points A, B and C, do the following: 
a. To specify points A and B, manually move the cutting head to the sheet edge 

in X-axis positive direction and click Set A and Set B. The system 
automatically connects points A and B to specify a new X-axis. 
X-axis coordinate of point A should be smaller than that of point B. 

b. To specify point C, manually move the cutting head to the sheet edge in Y-
axis positive direction and click Set C. 

The system automatically specifies a new Y-axis by taking a perpendicular line to 
line AB through point C and confirms a new WCS. 

4. Optional: To restore the current coordinate to the default value, click Reset ABC. 
5. To check the calculated locating result in Finding Result area, click Calculate in 

Hand 3-point area. 
If the rotation angle exceeds 15°, it indicates that the sheet is tilted. At this time, please 
place the sheet and do edge finding again. 
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2.6.3 Set Edge Finding by Two-point 

Before setting edge finding by two-point, in the machine control bar, click  to 
guide the position. 

To set edge finding by two-point, do the following: 

1. To switch to the page of two-point, in Finding Mode area of Edge Finding dialog 
box, click Hand 2-point: 

 
2. To specify the upper right / lower right / upper left / lower left point on the sheet as 

the origin O' of the new WCS, select a point in the drop-down box of O Pos. The 
corresponding diagram shows in Hand 2-point area. 

3. To define the new WCS by specifying point A, manually move the cutting head to 
the sheet edge in the positive direction of X-axis and click Set A. The system 
automatically connects points A and O’ to specify a new X-axis, and constructs a 
perpendicular line to line O'A through point O' to specify a new Y-axis. 

4. Optional: To restore the current coordinate to the default value, click Reset O'A. 
5. To check the calculated locating result in Finding Result area, click Calculate in 

Two-point area. 
If the rotation angle exceeds 15°, it indicates that the sheet is tilted. At this time, please 
place the sheet and do edge finding again. 
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2.7 Simulate Machining 
It is used to see the moving track of the machine tool before actual machining, so as to 
avoid damage to the machine tool due to programming mistakes in the toolpath file. 

It includes the following: 

 Simulation: to check the toolpath in real time without running the machine tool. It 
provides a fast but lifelike simulation environment. During simulation, no actual 
machining occurs, and only the moving track of the cutting head at high speed 
shows in the drawing window. 

 Frame cutting: to confirm the machining range by running the system along the 
frame of the toolpath. During frame cutting, no actual machining occurs. 

 Dry run: to move the machine tool without turning on the laser and related ports of 
laser. During dry run, no actual machining occurs. 

To simulate machining, do one of the following: 

 Simulation 
Note: Before simulation, make sure the toolpath file has been saved and the 
system is in idle status. 

o In the machine control area, click . 
o In the menu bar, click Machining → Mach Control → Simu. 
o On the keyboard, press F8. 

The machine tool starts simulation from the beginning of the toolpath file. 

 Frame cutting 

o In the machine control bar, click 。 

o In the menu bar, click Machining → Mach Control → Cut Frame. 

 Dry run 

o In the machine control area, click . 
o In the menu bar, click Machining → Mach Control → Dry Run. 
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2.8 Start Machining 
It is used to automatically execute the toolpath file from the beginning to the end until any 
intentional interruption. 

Before starting machining, make sure no E-stop and other alarms occur. 

To start machining, do one of the following: 

 In the machine control bar, click . 

 In the menu bar, click Machining → Mach Control → Start. 
The system starts machining from the beginning of the toolpath file. 

During machining, you can do the following: 

 To stop machining, do one of the following: 

o In the machine control bar, click . 
o In the menu bar, click Machining → Mach Control → Stop. 

Machining stops and the system enters idle status. 

 To execute breakpoint resume, do one of the following: 
Note: Before executing breakpoint resume, please make sure the machine 
coordinate is correct. Otherwise, please execute returning to the machine origin first. 

o In the machine control bar, click . 
o In the menu bar, click Machining → Mach Control → Resume. The system 

automatically continues to start machining from the exactly interrupted 
position. 
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3 Object Operations 
3.1 Drawing 
This part introduces the drawing tools that are used to draw objects in the drawing window 
for machining. 

To select a drawing tool, do one of the following: 

 In the drawing toolbar, select a drawing tool: 

o : Dot 

o : Polyline 

o : Line 

o : Elliptic arc 

o : Arc 

o : Ellipse 

o : Circle 

o : Polygon 

o : Star 

o : Rectangle 

o : Text 

 In the menu bar, click Drawing and select a drawing tool. 
After drawing, do the following: 

1. To exit drawing, right click or press Esc. 
2. To adjust the object, select the target object and do one of the following: 

o In the common toolbar, to modify the size and position of the object, directly 
input the values. 

o In the drawing window, to modify the size of the object, drag the rectangular 
points around the object. 

3.1.1 Draw a Polyline 
A polyline is a chain of lines and arcs that are joined together into one object. It includes 
line and tangent arc. The tangent arc corresponds to the arc. 

To draw a polyline, do the following: 

1. Click . 
2. Left click to specify two points to draw a line. 
3. Optional: To switch to the arc mode, right click on the drawing window and select 

Tangent Arc. 
The arc is tangent to the last line/arc. 
If you need to switch back to the line mode, right click on the drawing window and 
select Line. 

4. Left click to specify another point. 
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5. Right click and do one of the following: 
o To draw the end point of the polyline, select Confirm. The polyline is an 

unclosed object. 
o To connect the current point to the start point, click Close. The polyline is a 

closed object. 
o To cancel the previous operations and exit drawing a polyline, click Cancel. 

After drawing a polyline, to change an unclosed polyline into a closed one, select it and 
check Close in the common toolbar. (Note: This operation is irreversible.) 

3.1.2 Draw an Elliptic Arc 
To draw an elliptic arc, do the following: 

1. Click . 
2. Draw an ellipse. 

See Draw an Ellipse for details. 
3. Left click to separately specify the start point and the end point. 

3.1.3 Draw an Arc 
To draw an arc, do the following: 

1. Click . 
2. Left click to specify the center point. 
3. Left click to specify the start point. 

The distance between the start point and the center point is the radius. 
4. Left click to specify the end point. 

3.1.4 Draw an Ellipse 
To draw an ellipse, do the following: 

1. Click . 
2. Left click to specify the center point. 
3. Left click to separately specify two points. 

The distances between the center point and the two points are separately the major 
axis and minor axis of the ellipse. 

3.1.5 Draw a Circle 
To draw a circle, do the following: 

1. Click . 
2. Left click to specify the center point. 
3. Left click to specify a point. 

The distance between this point and the center point is the radius. 

3.1.6 Draw a Polygon 
To draw a polygon, do the following: 

1. Click . 
2. Set parameter Edges in the common toolbar and press Enter on the keyboard. 
3. Left click twice to separately specify the center point and a vertex. 
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3.1.7 Draw a Star 
To draw a star, do the following: 

1. Click . 
2. Set parameter Vertexes in the common toolbar and press Enter on the keyboard. 
3. Left click twice to separately specify the center point and a vertex. 

3.1.8 Enter Text 
It is mainly used to draw text in an advertisement board. 

To enter text, do the following: 

1. Click . 
2. To specify a text box, click and drag the mouse. 
3. Enter text in the input box. 

During this process, you can press Ctrl + Enter for line feed. 
4. Press Enter. 

3.2 Auxiliary Editing 
You can do the following for better effects of object editing: 

 View objects 

 Set catch options 

 Select objects 

 Measure distance 

 Check the objects 

 Switch to the fill mode 

3.2.1 View Objects 
It is used for a better view of objects without changing the actual sizes and coordinates. 

It includes the following: 

 Pan the view 

 Zoom in/out the view 

 Zoom in the selected area 

 Fit to window 

3.2.1.1 Pan the View 
It is used to reposition the drawing window by selecting a base point and a second point 
for the new position. 

To pan the view, do one of the following: 

 Press the mouse wheel and drag the mouse at the same time to move the view to 
the target position. 

 Do one of the following to call Pan command, and hold the left mouse button to 
move the view to the target position: 

o In the drawing toolbar, click  Pan. 
o In the menu bar, click View → Pan. 

To stop panning the view, right click or press Esc. 
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3.2.1.2 Zoom in/out the View 
It is used to zoom in or zoom out the view. Through changing the size of the shown area 
and objects, you can draw objects more precisely 

To zoom in/out the view, do the following: 

1. To call Zoom command, in the menu bar, click View → Zoom. 
2. Do one of the following: 

o Scroll up the mouse wheel to zoom in the view and scroll down the mouse 
wheel to zoom out the view. 

o Hold and drag up the left mouse button to zoom in the view, and hold and 
drag down the left mouse button to zoom out the view. 

o On the numeric keypad, press + to zoom in the view, and press - to zoom out 
the view. 

To stop Zoom command, right click or press Esc. 

3.2.1.3 Zoom in the Selected Area 
It is used to zoom in the selected part of the object to the size of the drawing window. 

To zoom in the selected area, do the following: 

1. To call Zoom by Rect command, do one of the following: 

o In the drawing toolbar, click  Zoom by Rect. 
o In the menu bar, click View → Zoom by Rect. 

2. Left click on the drawing window, drag the mouse to form a rectangle and left click 
again. The area formed by the rectangle zooms in. 

3.2.1.4 Fit to Window 
It is used to resize objects and make them fit to the drawing window on the premise of 
showing all objects. 

To fit to window, do one of the following: 

 In the drawing toolbar, click  Best View. 

 In the menu bar, click View → Best View. 

 On the numeric keypad, press *. 
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3.2.2 Set Catch Options 
It is used to precisely locate feature points and connect objects during drawing an object. 

Once the cursor moves close to the feature points, the system can easily locate to the 
points. 

To set catch options, do the following: 

1. To open Catch Option dialog box, do one of the following: 

o In the common toolbar, click  Catch Options. 
 In the menu bar, click Drawing → Catch Options. 

 
2. Check the feature items according to the shape of the object. 
3. Adjust the catch sensitivity. 

It is easier to get the feature points with higher catch sensitivity. 
4. Optional: If Custom is checked in Polar Axis area, to set the incremental angle, 

do the following: 
a. In the menu bar, click Drawing → Polar IncAngle. Polar Axis Inc. Angle 

dialog box pops up. 
b. Check Enable and set the incremental angle. 

The system catches feature points based on the set incremental angle. 
When the system rotates the set angle, a polar axis line appears. 

5. To enable catching function, do one of the following: 

o In the common toolbar, click  Catch. 
o In the menu bar, click Drawing → Catch. 
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3.2.3 Select Objects 
It is used to select objects for editing. 

To select objects, do one of the following: 

 Freely and manually select any objects. 

 Automatically select objects based on the same standard. 

3.2.3.1 Manually Select Objects 
To manually select objects, do the following: 

1. In the drawing toolbar, to call Select graph command, click  Select graph. 
2. Do one of the following: 

o To select a single object, left click the target object on the drawing window. 
o To select several objects, press Ctrl and left click the target objects one by 

one. 
o To select objects contained in the selected area, hold the left mouse button 

to drag from upper left to lower right. 
Objects intersected with the area will not be selected. 

o To select objects intersected with or contained in the selected area, hold the 
left mouse button to drag from lower right to upper left. 

3.2.3.2 Automatically Select Objects 
To automatically select objects, do one of the following: 

 Click  Select in the common toolbar, or click Edit → Select in the menu bar, 
and select one of the following in the drop-down box: 

o Select All: 
o Select Invert: 
o Select Unclosed: to automatically select all unclosed objects. 
o Select Tiny: to automatically select all objects within the target size. 
o Inner: 
o Outer: 
o Select Similar: to select all the similar objects after selecting one object, 

ignoring the difference of angle. 
o Select Similar(Strict in angle): to select all the similar objects after 

selecting one object, paying attention to the difference of angle. 

 In the menu bar, click Edit, and select one of the following: 
o Select by Layer: to automatically select all objects within the same layer. 
o Select by Inner-Outer: to automatically select objects based on the nesting 

(inner: select inner objects; outer: select outer objects): 

 
o Select by Type: to automatically select objects of the same type. 
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3.2.4 Measure Distance 
It is used to measure distance, X-axis / Y-axis offset and the vector angle between two 
points. 

To measure distance, do the following: 

1. To call Measure command, do one of the following: 

o In the drawing toolbar, click  Measure. 
o In the menu bar, click View → Measure. 

2. Left click to select the start point for measuring, and move the cursor to select the 
end point. 

The measurement result shows near the end point. 

3.2.5 Check the Objects 
It is used to examine the imported or drawn objects to see if there exist unclosed / self-
intersected / intersected / overlapped objects. 

To check the objects, do the following: 

1. In the menu bar, click View → Graphic Detection. Shape Check dialog box pops 
up: 

 
2. Select the target checking items. 

After checking the objects, Check Information dialog box pops up: 
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3.2.6 Switch to the Fill Mode 
It is used to view closed objects that are set as Fill. In the fill mode, objects set as Fill are 
filled in while and others are shown in the wireframe. 

All objects are shown in the wireframe by default.。 

To switch to the fill mode, in the menu bar, click View → Fill Mode: 

 

To switch to the wireframe mode, in the menu bar, click View → Wireframe Mode. 

3.3 Basic Editing 
It is used to edit drawn and imported objects, so as to modify the toolpath according to the 
requirement. 

It includes the following: 

 Translate objects 

 Rotate an object 

 Mirror an object 

 Align objects 

 Scale objects 

 Merge objects 

 Share an edge 

 Group objects 

 Ungroup objects 

 Explode objects 

 Break objects 

 Execute array 
After editing objects, you can click File → Export File to import the target objects as a 
DXF / DWG file in the menu bar for later use. 

3.3.1 Translate Objects 
It is used to move objects a certain distance. As a result, the coordinate of objects will be 
changed without changing the size of objects. 

To translate objects, select the target objects, and do the following: 

 Press the left mouse button and drag the objects. 

 On the keyboard, press ↑ / ↓ / ← / →. 

 Call Translate command: 

a. Click  Transf → Translate in the common toolbar, or click Edit → 
Translate in the menu bar. 

b. Left click on the drawing window. 
c. Move the cursor to the target position and click again. 
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3.3.2 Rotate an Object 
It is used to move or turn an object around a certain fixed point, so as to change the 
position and direction of the object. 

To rotate an object, select the target object, and do one of the following: 

 Left click to define a point. 
The point is the rotation center by default. 

 In the common toolbar, enter the rotation angle in Angle input box and press Enter. 
o If the object is a rectangle or text, the lower left point of the object is the 

rotation center: 

 
o If the object is a/an star, polygon or ellipse, the center point of the object is 

the rotation center: 

 
 Call Rotate command: 

a. In the common toolbar, click  Transf→ Rotate, or click Edit → Rotate. 
b. Left click to select the rotation center. 
c. Move the cursor to adjust the rotation angle. 
d. Left click to confirm. 

3.3.3 Mirror an Object 
It includes the following: 

 Vertical mirror: mirror along X-axis with the center of the object as the center of 
rotation. 

 Horizontal mirror: mirror along Y-axis with the center of the object as the center of 
rotation. 

To mirror an object, select an object, and do one of the following: 

 In the common toolbar, click  Transf → Vertical Mirror / Horizontal Mirror. 

 In the menu bar, click Edit → Mirror → Vertical Mirror / Horizontal Mirror. 
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3.3.4 Align Objects 
It is used to arrange the objects in a straight line. 

To align objects, select several objects and do one of the following: 

 To align objects by the center point, in the drawing toolbar, click  Align Center 
Point. 

 In the menu bar, click Edit → Align, and select one of the following: 
o Align Left 
o Align Right 
o Align Top 
o Align Bottom 
o Align Center Point 
o Align Horizontally 
o Align Vertically 
o Distribute Horizontally 
o Distribute Vertically 

The system automatically aligns objects. 

3.3.5 Scale Objects 
It is used to make objects appear larger/smaller in the equal proportion. 

To scale objects, select the target objects, and do the following: 

 In the common toolbar, enter the scaling factor in Scale input box and press Enter. 

 In the menu bar, call Scale command: 
a. Click Edit → Scale. 
b. Left click to select the center point for scaling. 
c. Move the cursor to adjust the scaling factor. 
d. Left click to confirm. 

3.3.6 Merge Objects 
It is used to combine unclosed objects within the set tolerance, so as to help to avoid 
unnecessary tool lifting and improve machining efficiency. 

Tolerance is the allowable distance between objects that need to be combined. 

The target objects cannot be the following: 

 Closed object 

 Dot 

 Text 

 Group 
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Before merging objects, it is suggested to enable catch options. 

To merge objects, select the target objects, and do the following: 

1. To open Join dialog box, do one of the following: 

o In the common toolbar, click  Merge. 
o Right click on the drawing window and select Merge. 
o In the menu bar, click Edit → Merge. 

 
2. Set parameter Tolerance. 

Range: 0.01mm~10mm 
3. Select a priority strategy to decide the standard for combining. 

If there exist more than two end points that can be combined, the system combines 
objects that are nearest / longest / in the same direction. 

4. Optional: Check Merge among different layers. The system merges objects of 
different layers into the layer with a higher layer order. 

The result is as follows: 

 

3.3.7 Share an Edge 
It is used to make the overlapped edges become a shared edge, so as to avoid cutting the 
same edge during machining, and optimize the toolpath. 

The error for sharing an edge is 0.1mm. 

Before sharing an edge, make sure the following: 

 The shared objects are closed objects and share the same point. 

 The shared edge is a line or an arc. 
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To share an edge, select at least two objects, do the following: 

1. To open Common Edge dialog box, do one of the following: 
o Right click on the drawing window, and click Common Edge. 
o In the menu bar, click Planning → Common Edge. 

 
2. Select a strategy for sharing an edge: 

o Grind: cut internal objects first. 
o C Type: cut objects in the shape of character C. 

3. Optional: If the strategy is C Type, select a machining order: 
o From Bottom to Top: cut objects from bottom to top. 
o From Left to Right: cut objects from left to right. 
o Diagonal Extend: cut objects in the lower-left region first and cut its adjacent 

objects circle. The toolpath is like an ever-widening arc. The marching 
direction is from the lower-left region to the upper-right region. 

o Stair-step Extend: it is applicable to rectangular objects. Its toolpath is like 
stair steps. The extending direction is from the lower-left region to the upper-
right region. 

4. Optional: Check the following items in Others area: 
o Share Edge among Layers: to make objects in the different layers share the 

edge. 
o Share Point: to make objects that share the same point as a group. 
o Extend Starting Point: to extend the toolpath in the opposite machining 

direction through the start point and turn on the laser in advance, helping 
completely cut the start point and avoid over-burning. 
It is applicable to rectangular objects. 

o Prevent Collision: to avoid colliding with the cutting head after cutting parts 
in the first region of shared objects. 
It is only applicable to strategy C Type. With it checked, the shared edge will 
be cut in the second region. Otherwise, the shared edge will be cut in the first 
region. 

After sharing an edge, the objects turn into a group. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

40 / 119 

3.3.8 Group Objects 
It is used to bind several objects, so as to edit them at the same time. 

To group objects, select several objects, and select one of the following: 

 In the common toolbar, click  Group. 

 In the drawing window, right click and select Group. 

 In the menu bar, click Edit → Group/Ungroup → Group. 
The result is as follows: 

 

3.3.9 Ungroup Objects 
It is used to separate the grouped objects, so as to edit each part of the objects 
independently. 

To ungroup objects, select the target group, and do one of the following: 

 In the common toolbar, click  Ungroup. 

 Right click on the drawing window and select Ungroup. 

 In the menu bar, click Edit → Group/Ungroup → Ungroup. 

3.3.10 Explode Objects 
It is used to delete extra lines, so as to trim the toolpath. It usually applies to polylines. 

It is suggested to use it together with merging function, to correct mistakes by drawing and 
make sure machining quality: 

 If the object is a group, exploding objects is equal to ungrouping objects. 

 If the object is text, exploding objects is equal to turning the text into polylines. 
To explode objects, select the target objects, and do one of the following: 

 In the common toolbar, click  Explode. 

 In the menu bar, click Edit → Explode. 
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The result is as follows: 

 

3.3.11 Break Objects 
It is used to cut objects into several polylines. 

It is usually used in the following situations: 

 Connect the cutting part to its surrounding material. It equals to micro joint. 

 Cut extra objects during drawing objects. 
To break objects, do one of the following: 

 To break all the selected objects at the same time, automatically break objects. 

 To break one object each time by freely selecting breaking position, manually break 
an object. 

3.3.11.1 Automatically Break Objects 
To automatically break objects, select the target objects, and do the following: 

1. In the menu bar, click Edit → Break. Break dialog box pops up: 

 
2. Select Automatically and enter the number and distance of breaking lines. 

The result is as follows: 
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3.3.11.2 Manually Break an Object 
To manually break an object, do the following: 

1. In the menu bar, click Edit → Break. Break dialog box pops up: 

 
2. Select Manually and enter the distance of breaking lines. 

3. Click OK. The cursor turns to . 
4. Left click to select the positions for breaking. 
5. Right click to finish breaking. 

The result is as follows: 

 

3.3.12 Execute Array 
It is used to copy the machining objects and arrange them in order, so as to improve 
machining efficiency. 

Array includes the following: 

 Rectangular array 

 Circular array 

 Manual array 
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3.3.12.1 Execute Rectangular Array 
It is used to copy the machining objects and arrange them in a rectangular array. 

To execute rectangular array, select the target objects, and do the following: 

1. To open Rectangular Array dialog box, do one of the following: 

o In the common toolbar, click  Array. 

o In the common toolbar, click the drop-down box of  Array, and select 
Rectangular Array. 

o In the menu bar, click Drawing → Array → Rectangular Array. 

 
2. Set the number of rows and columns for array. 
3. In Offset area, select one of the following ways: 

o Offset: based on the center of the object. 
o Space: based on the frame of the objects. 

4. Select the direction for rows and columns. 
The result is as follows: 
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3.3.12.2 Execute Circular Array 
By taking a certain point as the center, it is used to copy the objects and arrange them in a 
circle array. 

To execute circular array, select the target object, and do the following: 

1. To open Circular Array dialog box, select one of the following: 

o In the common toolbar, click the drop-down box of  Array, and select 
Circular Array. 

o In the menu bar, click Drawing → Array → Circular Array. 

 
2. Set coordinates of the center point for rotation. 
3. Set parameters Array Counts and Array Angle. 

The result is as follows: 
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3.3.12.3 Execute Manual Array 
It is used to manually draw a range shaped in a rectangle for array. Objects will be copied 
in the rectangle. 

To execute manual array, select the target object, and do the following: 

1. To open Manual Array dialog box, select one of the following: 

o In the common toolbar, click the drop-down box of  Array, and select 
Manual Array. 

o In the menu bar, click Drawing → Array → Manual Array. 

 
2. To set the space between rows and columns, set parameters Row Dist and Col 

Dist. 
3. Optional: To delete the original object after array, check Delete the Original 

Graph. 

4. Click OK. The cursor turns into . 
5. To select the start position, right click. 
6. Optional: To enter into manual array, right click on the drawing window. 

Note: Without selecting the start position, right clicking on the drawing window will 
exit manual array. 

7. To select the end position, drag the mouse and left click. 
The result is as follows: 
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3.4 Preprocessing 
Before actual machining, you can process objects in advance. 

Preprocessing operations include the following: 

 Preprocess objects with one click 

 Delete overlapped lines 

 Simplify curves 

 Smooth curves 

 Turn polylines into circles 

 Trim self-intersecting polylines 

 Turn text into polylines 

3.4.1 Preprocess Objects with One Click 
It is used to preliminarily and automatically process objects with one click. 

To preprocess objects with one click, select the target objects, do the following: 

1. To open Instant Preprocess dialog box, do one of the following: 

o In the common toolbar, click  Preprocess. 
o Right click on the drawing window, and select Instant Preprocess. 
o In the menu bar, click Edit → Instant Preprocess. 
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2. Check the target items and set values of parameters. 
o Simplify curves. 
o Delete overlapped lines. 
o Merge objects 
o To delete all dots, check Delete Dots. 
o To delete tiny circles within the set diameter, check Delete Mini-circles, and 

set the diameter. 
o To delete tiny curves within the set dimension, check Delete Mini-curves, 

and set the scale. 
o Trim self-intersecting polylines. 
o To change the technics tiny circle cutting into piercing technics, check Hole 

and set parameter Hole Diameter. 
o Turn polylines into circles. 
o Automatically set fill and unfill. 
o Specially show unclosed objects. 
o Automatically change the machining order  

3. Optional: Check Apply when Importing. The system processes the objects 
automatically according to the selections above after importing a toolpath file. 

3.4.2 Delete Overlapped Lines 
The target objects for this operation should meet one of the following demands: 

 Totally overlapped objects 

 Partly overlapped objects that share at least one line 

 Overlapped lines in the object(s) 
To delete overlapped lines, select the target objects, and do the following: 

1. To open Delete Overlap Lines dialog box, do one of the following: 
o Right click on the drawing window, and select Delete Overlap Lines. 
o In the menu bar, click Edit → Delete Overlap Lines. 

 
2. Set the following parameters: 

o Tolerance: the distance between two lines. 
o Min Length: the minimum overlapped length of two lines. 

The system automatically deletes self-overlapping lines within the tolerance and saves one 
line. 

The result is as follows: 
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3.4.3 Simplify Curves 
It is used to reduce the number of control points for polylines, so as to speed up the 
response time to object operations. 

The control points are used to control and adjust the shapes of polylines. 

To simplify curves, select the target object, and do the following: 

1. In the menu bar, click Edit → Simplify Curve. Simplify Curves dialog box pops up. 
2. Set parameter Tolerance. 

The system automatically reduces the number of control points for polylines within the set 
tolerance. 

3.4.4 Smooth Curves 
It is used to make polylines flat and even, so as to improve machining efficiency. 

To smooth curves, select the target objects, and do one of the following: 

 In the common toolbar, click  Smooth Curve. 

 Right click on the drawing window, and select Smooth Curve. 

 In the menu bar, click Edit → Smooth Curve. 
After smoothing curves, the prompt Smooth curve successfully shows. 

3.4.5 Turn Polylines into Circles 
It is used to turn closed polylines shaped like circles into circles. 

To turn polylines into circles, select the target objects, and do the following: 

1. To open Polyline to Circle dialog box, do one of the following: 
o Right click on the drawing window, and select Polyline to Circle. 
o In the menu bar, click Edit → Polyline to Circle. 

 
2. According to the schematic diagram, set parameters Tolerance and Relative Error. 
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After successfully turning polylines into circles, the following dialog box pops up: 

 

The result is as follows: 

 

3.4.6 Trim Self-intersecting Polylines 
It is used to separate self-intersecting polylines and trim extra lines. 

To trim self-intersecting polylines, select the target objects, and do the following: 

1. In the menu bar, click Edit → Trim Self-intersection. Trim Self-intersection 
dialog box pops up. 

2. Set parameter Length. 
The system automatically trims lines of which the length is within the set value and divides 
a polyline into several objects. 

The result is as follows: 
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3.4.7 Turn Text into Polylines 
It is used to turn text into polylines, so as to edit some parts of the text. 

To turn text into polylines, do the following: 

 Right click on the drawing window, and select Text to Polylines. 

 In the menu bar, click Edit → Text to Polylines. 

3.5 Batch Modifying 
It is used to modify the target objects and objects with the same shape and size at the 
same time. 

To modify objects in batch, select the target object, and do the following: 

1. To call batch modifying command, select one of the following: 
o Right click on the drawing window, select Quantity Modify. 
o In the menu bar, click Edit → Quantity Modify. 

2. Optional: Do one of the following based on your needs: 

 
o To modify the target object only, check Modify Itself: 

Otherwise, the system will modify objects with the same shape and size. 
o Not to modify objects with the same shape and size but with different rotation 

angles, check Distinguish Angle. 
3. Do the following: 

o View objects 
o Measure distance 
o Add chamfer 
o Set unfill or fill 
o Set a lead line 
o Set kerf compensation 
o Execute micro joint 
o Chop an object 
o Set ring cut 
o Release angles 
o Change the machining direction 
o Preprocess objects with one click 
o Do layer setting 
o Do clearing  
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4 Technics 
4.1 Set Unfill or Fill 
It is used to reserve a certain part of closed objects. For objects set as unfill attribute, the 
system reserves the outer part; for objects set as fill attribute, the system reserves the 
inner part. 

To set unfill or fill, select closed objects, and do the following: 

1. Call Unfill/Fill command: 

o In the common toolbar, click  Unfill/Fill. 
o Right click on the drawing window, and click Unfill/Fill. 
o In the menu bar, click Technics → Unfill/Fill. 

2. Select one of the following: 
o To manually set the selected objects as unfill/fill, select Unfill / Fill. 
o To set the selected objects as unfill by default, select Auto. 

After setting unfill/fill, check unfill/fill attribute by switching to the fill mode. 

4.2 Set a Lead Line 
It is used to avoid machining errors or damage to the workpiece caused by laser staying 
above the start position for a long time, so as to improve machining accuracy. 

The type of lead line differs in the leading direction: 

 Lead-in line: consisting of line, arc and hook. 

 Lead-out line: consisting of line and arc. 
To set a lead line, select the target object, and do the following: 

1. To open Set dialog box, do one of the following: 

o In the common toolbar, click  Lead Line. 
o Right click on the drawing window, select Lead Line → Set. 
o In the menu bar, click Technics → Lead Line → Set. 
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2. Select a type for the lead line according to the cutting technics. 
3. Set related parameters of the lead line. 

See Parameters for details. 
4. Optional: If the target object is a closed object, in Seal area, select one of the 

following: 
o Gap: the lead line is unclosed and the cutting head will not cut through at the 

sealing position. 
o Over: the lead line is closed and the cutting head will cut at the sealing 

position. 
Alternatively, in the menu bar, click Technics → Lead Line → Gap / Over Cut. 

5. Set the position of the lead line: 
o If you check Automatic Lead Position, do one of the following: 

 To automatically set the lead line at the position with a larger angle in 
the object, check Corner first. 

 To automatically set the lead line at the longest edge of the object, 
check Edge first. 

o If you check Set by Universal (0~100) param. The position of the lead line 
is the set ratio times the total length. 

o If you check Set by Mouse, click on the edge of the object after the cursor 

turns into  to specify the position of the lead line. 
6. In Options Area, select one of the following: 
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o Retain Position, Change Leads Type 
o Retain Leads Type, Change Position 

7. Optional: Manually modify the lead line: 
a. Call Start Point command: 

 In the common toolbar, click  Start Point. 
 Right click on the drawing window, select Lead Line → Start Point. 
 In the menu bar, click Technics → Lead Line → Start Point. 

b. Do one of the following: 
 To modify the position of the lead-in line, left click on the edge of the 

object. 
 To draw a line-type lead-in line from outside to the edge on the object, 

left click on the outside and the edge of the object. 
The result is as follows: 

 

Parameters 

 Angle: for a line-type lead line, it refers to the angle between the lead line and the 
tangent line of the intersection; for an arc-type lead line, it refers to the central angle. 

 Length: for a line-type/arc-type lead line, it refers to the length of the line/arc; for a 
hook-type lead line, it refers to the sum of the radius of the arc and the length of the 
line. 

 Radius: for a hook-type lead line, it refers to the radius of the arc. 

 Add Tiny Circle in Start Point: to add a tiny circle at the start point of the lead-in 
line, so as to solve the problem that the accumulation of slag influences cutting 
effect during piercing a thick tube. 

 Circle Radius: the radius of the hole at the start point of the lead line. 
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4.3 Change the Machining Direction 
It is used to change the machining direction. After drawing an object, the default machining 
direction is counterclockwise. 

Before changing the machining direction, to show the machining direction, do one of the 
following: 

 In the common toolbar, click  Show Direction. 

 In the menu bar, click View → Show Direction. 
To change the machining direction, do the following: 

1. To open Direction dialog box, do one of the following: 

o In the common toolbar, click  Mach Dir. 
o Right click on the drawing window, select Mach Direction → Set. 
o In the menu bar, click Technics → Mach Direction → Set. 

 
2. Select the machining direction based on your needs. 

Alternatively, if you just need to reverse the machining direction, do one of the 
following: 

o In the common toolbar, click  Mach Dir → Reverse. 
o Right click on the drawing window, select Mach Direction → Reverse. 
o In the menu bar, click Technics → Mach Direction → Reverse. 

3. Optional: To skip the machining direction of groups, in Advanced Option area, 
check Skip Groups. 

4.4 Change the Machining Order 
It is used to change the machining order. After drawing several objects, the default 
machining order is the drawing order. 

To show the machining order, do one of the following: 

 In the common toolbar, click  Show Order. 

 In the menu bar, click View → Show Order. 
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4.4.1 Automatically Change the Machining Order 
The system automatically sorts objects according to the selected sorting strategy. 

To automatically change the machining order, select the target objects, and do the 
following: 

1. To open Auto Sorting, do one of the following: 

o In the common toolbar, click  Sort. 

o In the common toolbar, click the drop-down box of  Sort, and select Auto. 
o Right click on the drawing window, and select Mach Order → Auto Sorting. 
o In the menu bar, click Planning → Auto Sorting. 

 
2. In Sort Strategy area, select a sorting strategy. 
3. In Advanced Options, check advanced option(s): 

o Divide Grid 
 AutoSet: to automatically divide objects into the same group based 

on the distance and count. 
 Fixed Value: the objects whose distance is less than the set value will 

be divided into the same group. 
o Color: to sort objects in the part according to the layer order. It only 

applicable to the part with nested relation. 
o Small Objects First: to sort objects whose sizes are less than the set value. 

It only applicable to part interior with nested relation. 
o Sort in Group: to sort objects in groups according to the sort strategy. 
o Allow Reverse Direction: to change the machining direction and start 

position. 
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To separately set the order for the objects in a group, select one of the following to open 
Sort dialog box and select a sorting strategy and advanced option(s): 

 In the common toolbar, click the drop-down box of  Sort → Sort within Group. 

 Right click on the drawing window, click Mach Order → Sort within Group. 

 In the menu bar, click Planning → Sort within Group. 

4.4.2 Manually Change the Machining Order 
It is used to manually specify the machining direction for a single object or several objects. 

To manually change the machining order, do the following: 

1. To call Manual Sorting command, do one of the following: 

o In the common toolbar, click  Sort → Manual Sorting. 
o Right click on the drawing window, and select Mach Order → Manual 

Sorting. 
o In the menu bar, click Planning → Manual. 

The cursor turns into , and the system automatically shows the machining order. 

2. Select the first target object. The cursor turns into , the machining order on the 
object turns into 1, and the order of other objects turns into 2,3 ... in sequence on 
the basis of previous order. 

3. Optional: To reset the last order number, right click and select Previous Order. 
4. Repeat step 2 and click the objects in order. 

After manually changing the machining order, to exit Manual Sorting command, right click 
and select Exit, or press Esc. 

4.4.3 Specify the Machining Order for a Single Object 
It is used to specify the machining order for a single object. 

To specify the machining order for a single object, select a single object, and do the 
following: 

1. To open Specify Order Separately dialog box, do one of the following: 

o In the common toolbar, click  Sort → Specify Separately. 
o Right click on the drawing window, click Mach Order → Specify Separately. 
o In the menu bar, click Planning → Specify Separately. 

 
2. To specify an order, enter an order in Number \[1, n] input box. 

n is the maximum machining order in the toolpath. 

4.4.4 Change the Machining Order in a List 
Each object has a number. This operation is used to manually change the machining order 
according to the number. 
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To change the machining order in a list, select a single object, and do the following: 

1. To open Order List dialog box, do one of the following: 

o In the common toolbar, click  Sort → Order List. 
o Right click on the drawing window, click Mach Order → Order List. 
o In the menu bar, click Planning → Order List. 

 
2. Check the number, and do one of the following to sort the machining order: 

o Click Move Up / Move Down to move the object. 
o Double click another object to move the checked object to the clicked 

position. 

4.4.5 Change the Machining Order by Manual Drawing 
It is used to manually change the machining order of two objects, and then change the 
whole machining order. 

To change the machining order by manual drawing, select the target objects, and do the 
following: 

1. To call Manual Draw Sorting command, do one of the following: 

o In the common toolbar, click the drop-down box of  Sort → Manual Draw 
Sorting. 

o Right click on the drawing window, click Mach Order → Manual Draw 
Sorting. 

o Select no object, right click on the drawing window, click Manual Draw 
Sorting. 

o In the menu bar, click Planning → Manual Draw Sorting. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

58 / 119 

2. Select a single object. The object is highlighted: 

 
3. Hold the left button, draw a line from the object, connect it to another object (the 

target object), and release the mouse until the target object is highlighted. 
The machining order of the target object is behind the selected object at the first time. 

After changing the machining order by manual drawing, to exit Manual Drawing command, 
right click and select Exit, or press Esc. 

4.4.6 Sort to the Top or Bottom 
It is used to turn the machining order of a single object to the top or bottom. 

To sort to the top or bottom, select a single object, and do one of the following: 

 In the common toolbar, click the drop-down box of  Sort → Sort to the Top / 
Sort to the Bottom. 

 Right click on the drawing window, and select Mach Order → Sort to the Top / 
Sort to the Bottom. 

 In the menu bar, click Planning → Sort to the Top / Sort to the Bottom. 

4.5 Set Kerf Compensation 
There exists deviation between the sizes of actual cutting parts and theoretical ones, 
which is caused by the kerf during cutting. The deviation leads to a smaller size in the 
outer contour and a larger size in the inner contour. This operation is used to compensate 
the deviation. 

The type of kerf compensation includes the following: 

 All shrink: to shrink the cutting area for all selected parts. 

 All expand: to expand the cutting area for all selected parts. 

 Unfill: shrink; fill: expand: to shrink the cutting area for parts with unfill attribute, and 
expand the cutting area for parts with fill attribute. 
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Before setting kerf compensation, make sure the following: 

 The text has been turned into polylines  

 At least a closed object exists. 
To compensate the kerf, select the closed objects, and do the following: 

1. To open Kerf Compensation dialog box, do one of the following: 

o In the common toolbar, click  Comp. 
o In the menu bar, click Technics → Kerf Compensation. 

 
2. Select a compensation type. 
3. Set the inner width and outer width. 
4. Optional: To save the commonly used inner width and outer width for later use, do 

the following: 
a. In the drop-down box of Configuration, select Edit. Configuration dialog 

box pops up: 

 
b. Click Add, set a name in Description column, set the inner width in Inner 

Width column, and set the outer width in Outer Width column. 
c. For later use, in the drop-down box of Configuration, select the set name. 

The system automatically fills in the inner width and outer width. 
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The result is as follows: 

 

4.6 Execute Instant Setting 
It is used to set unfill/fill, lead line, machining direction, machining order and kerf 
compensation with one click, so as to improve machining efficiency. 
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To execute instant setting, select the target objects, and do the following: 

1. To open Instant Setting dialog box, do one of the following: 

o In the common toolbar, click  InstantSet. 
o Right click on the drawing window, and select Instant Setting. 
o In the menu bar, click Technics → Instant Setting. 

 
2. Set the target objects based on your needs. 
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4.7 Set Scan Cutting 
It is used to replan a toolpath to find the most efficient path to execute machining by 
controlling laser on/off, so as to avoid unnecessary tool lifting and feeding and improve 
machining efficiency. 

It differs in the object type: 

 Set scan cutting for lines. 

 Set scan cutting for arcs. 

 Set scan cutting for LED advertisement words. 

 Set scan cutting for runways. 

 Set scan cutting for sectors. 

 Set scan cutting for rings. 

4.7.1 Set Scan Cutting for Lines 
To set scan cutting for lines, select the target objects, and do the following: 

1. To open Line Scan pops up, do one of the following: 

o In the common toolbar, click  Scan. 

o In the common toolbar, click the drop-down box of  Scan, and select 
Line Scan. 

o In the menu bar, click Planning → Scan → Line Scan. 

 
2. Select the start position for cutting, and set the following parameters: 

o Max Scan Space: if the distance between objects sharing a common edge is 
greater than the set value, objects will be divided into two groups to do scan 
cutting. 

o Colinear Tolerance: if the distance between two parallel lines in objects is 
less than the set value, the two lines will be regarded as a common edge. 
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The result is as follows: 

 

4.7.2 Set Scan Cutting for Circles 
To set scan cutting for circles, select the target objects, and do the following: 

1. To open Arc Scan dialog box, do one of the following: 

o In the common toolbar, click the drop-down box of  Scan, and select Arc 
Scan. 

o In the menu bar, click Planning → Scan → Arc Scan. 

 
2. Optional: To select a sorting strategy, check Sort. 

Default sorting strategy: Out -> In. 
The result is as follows: 
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4.7.3 Set Scan Cutting for LED Advertisement Words 
To set scan cutting for LED advertisement words, select the target objects, and do the 
following: 

1. To open LED Scan dialog box, do one of the following: 

o In the common toolbar, click the drop-down box of  Scan → LED Scan. 
o In the menu bar, click Planning → Scan → LED Scan. 

 
2. Set a sorting strategy: 

o Inside Sort: to sort all circles in the inner of the target objects, and form a 
scanning group. 

o Border Sort: to sort objects based on the frames of the target objects. 
Taking sorting strategy Inside Sort as an example, the result is as follows: 
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4.7.4 Set Scan Cutting for Runways 
To set scan cutting for runways, select the target objects, and do the following: 

1. To open Runway Scan dialog box, select one of the following: 

o In the common toolbar, click the drop-down box of  Scan → Runway 
Scan. 

o In the menu bar, click Planning → Scan → Runway Scan. 

 
2. Set the following parameters: 

o Angle Tolerance: if the angle difference is less than the set tolerance, the 
target objects are parallel. Range: 0°~5°. 

o Size Tolerance: if the height difference between two runways is less than 
the set tolerance, the sizes of target objects are the same. Range: 
0mm~1mm. 

The result is as follows: 
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4.7.5 Set Scan Cutting for Sectors 
To set scan cutting for sectors, select the target objects, and do the following: 

1. To open Sector Scan dialog box, do one of the following: 

o In the common toolbar, click the drop-down box of  Scan → Sector Scan. 
o In the menu bar, click Planning → Scan → Sector Scan. 

 
2. Set the following parameters: 

o Center Tolerance: if the distance between circle centers of two circular rings 
is less than the set tolerance, the target objects are in a scanning group. 

o Radius Tolerance: if the radius difference between two circular rings is less 
than the set tolerance, the target objects are in a scanning group. 

The result is as follows: 
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4.7.6 Set Scan Cutting for Rings 
To set scan cutting for rings, do the following: 

1. To open Ring Scan dialog box, do the following: 

o In the common toolbar, click the drop-down box of  Scan. 
o In the menu bar, click Planning → Scan → Ring Scan. 

 
2. Optional: Check Sort and select the sorting direction. 

The result is as follows: 
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4.8 Add Release Angles 
It is used to cut out a fan-shaped area at the bending corner of a bent workpiece during 
bending process after machining, so as to solve the uplift of workpiece at the bending 
corner. 

To add release angles, do the following: 

1. To open Release Angle dialog box, click Technics → Release Angle: 

 

2. Set parameter Angle and Radius. The cursor turns into . 
3. To select an adding position, move the mouse to the target position and left click. 

To exit adding release angle, right click on the drawing window or press Esc. 

The result is as follows: 

 

4.9 Add a Chamfer 
It is used to add chamfers to objects whose angles are less than 180°, so as to improve 
cutting effect on corners of thick material. 

To add a chamfer, do one of the following: 

 Automatically add a chamfer to the selected and qualified objects according to the 
set value. 

 Manually select a chamfer position based on your need. 
Angle range: (0, 180)° 
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4.9.1 Automatically Add a Chamfer 
To automatically add a chamfer, select the target object, and do the following: 

1. To open Chamfer dialog box, do the following: 

o In the common toolbar, click  Chamfer. 
o Right click on the drawing window, and select Chamfer. 
o In the menu bar, click Technics → Chamfer. 

 
2. Set parameter Angle and Radius. 
3. Optional: To automatically add chamfers for closed objects according to attribute 

Unfill / Fill, check Create Chamfer by Fill or Unfill. 
Taking setting parameter Angle to 45°~90° and checking Create Chamfer by Fill or 
Unfill as an example, the result is as follows: 

 

4.9.2 Manually Add a Chamfer 
To manually add a chamfer, do the following: 

1. To open Chamfer dialog box, do the following: 

o In the common toolbar, click  Chamfer. 
o Right click on the drawing window, and select Chamfer. 
o In the menu bar, click Technics → Chamfer. 
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2. Set parameter Radius. 
3. Optional: To automatically add chamfers for closed objects according to attribute 

Unfill / Fill, check Create Chamfer by Fill or Unfill. 

4. Click Set by Mouse. The cursor turns into . 
5. To select an adding position, move the mouse to the target position and left click. 

After manually adding a chamfer, to exit Chamfer command, right click. 

Taking unchecking Create Chamfer by Fill or Unfill as an example, the result is as 
follows: 

 

4.10 Bridge Objects 
It is used to create a disconnected toolpath and connect objects with a bridge, so as to 
reduce piercing counts without scattering the parts after cutting. And it is mostly used to 
connect strokes of characters. 

Before bridging objects, make sure text has been turned into polylines. 

To bridge objects, select the target object, and do the following: 

1. To open Bridge dialog box, do one of the following: 

o In the common toolbar, click  Bridge. 
o In the menu bar, click Technics → Bridge. 

 

2. Set parameters Max Space and Width, and click OK. The cursor turns into . 
3. To select the ends of the bridging parts, left click. 

After bridging objects, to exit Bridge command, right click or press Esc. 
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The result is as follows: 

 

4.11 Execute Micro Joint 
It is used to connect the cutting part with surrounding material without falling down the 
material. By doing this, you can avoid the problem that the part becomes warped and 
collides with the cutting head moving at high speed, because the cutting part can neither 
fall from the gap of supporting rods nor be held by the supporting rods. 

To execute micro joint, do one of the following: 

 Automatically execute micro joint to selected objects according to the set count or 
space. 

 Manually select micro joint position based on your need. 

4.11.1 Automatically Execute Micro Joint 
To automatically execute micro joint, do the following: 

1. To open Micro Joint dialog box, do one of the following: 

o In the common toolbar, click  Micro Joint. 
o In the menu bar, click Technics → Micro Joint. 

 
2. In Auto area, select a strategy for micro joint and set related parameters. 
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3. Optional: To ignore tiny objects within a value during executing micro joint, check 
Skip Tiny Objects and set parameter Perimeter. 

4. Check Corner Evading, and set parameter Evading (range: 0.001mm~10mm) and 
Corner Angle (90°~180°). 
Otherwise, the system will execute micro joint for all points. 

Taking selecting strategy By Counts and setting parameter Counts to 2 as an example, 
the result is as follows: 

 

4.11.2 Manually Execute Micro Joint 
To manually execute micro joint, do the following: 

1. To open Micro Joint dialog box, do one of the following: 

o In the common toolbar, click  Micro Joint. 
o In the menu bar, click Technics → Micro Joint. 

 
2. In Manual area, select Manual Joint, and set parameter Length. 
3. Check Corner Evading, and set parameter Evading (range: 0.001mm~10mm) and 

Corner Angle (90°~180°). 
Otherwise, the system will execute micro joint for all points. 

4. Click OK. The cursor turns to . 
5. To select a position for micro joint, left click. 

After manually executing micro joint, to exit Micro Joint command, right click. 
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The result is as follows: 

 

4.12 Chop an Object 
It is used to divide the selected closed objects into several parts, so as to chop machining 
waste and make it fall easily. 

Before chopping an object, make sure the object meets the following requirements: 

 It is a closed object (except text) whose attribute is not Fill. 

 It is large (the distance between the chopping line and the object is not less than 
0.3mm, and the length of the chopping line should not less than 1mm). 

 It has not been executed micro joint. 

 It does not contain other objects in it. 
To chop an object, select the target object, and do the following: 

1. In the menu bar, click Technics → Chop. Chop dialog box pops up. 
2. Set parameter Space. 

The result is as follows: 

 

4.13 Set Ring Cut 
It is used to overcut the acute angle and loop around, so as to avoid over burn. 

Before setting ring cut, set unfill / fill according to the actual situation. 

To set ring cut, select the target object, and do the following: 

1. In the menu bar, click Technics → Ring Cut. Ring Cut dialog box pops up. 
2. Set parameter Angle to 0°~90° and parameter Length to 0.1mm~100mm. 
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The result is as follows: 

 

4.14 Set the Berth Point 
A point on the target object will coincide with the workpiece origin according to the set 
berth point. For example, if the berth point is set as bottom left, the upper right corner of 
the target object will coincide with the workpiece origin. 

It is used with the operation of setting the workpiece origin. 

To set the berth point, do the following: 

1. To open Set Berth Point dialog box, select one of the following: 

o In the common bar, click  Set Berth. 
o In the menu bar, click Machining → Set Berth Point. 

 
2. Select the berth position. 
3. Optional: To move the object to the workpiece origin by the set berth point, check 

Auto apply berth point and click  in the machine control bar. 
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4.15 Do Clearing 
It is used to clear some set technics. 

The clearing items include the following: 

 Lead line 

 kerf compensation 

 Micro joint 

 Chop 

 Scan cutting 

 Ring cut 
To do clearing, select the target objects, and do one of the following, and select the target 
clearing item: 

 In the common toolbar, click  Clear. 

 Right click on the drawing window, select Clear. 

 In the menu bar, click Technics → Clear. 
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5 Layer 
5.1 Overview 
As a core function, layer function is used to set technics for different layers. 

You can select one of the following to open Layer Setting dialog box: 

 In the layer toolbar, click  Layer. 

 In the menu bar, click Technics → Layer Setting. 
The Layer Setting dialog box is as follows: 

 

1. Layer selection bar 
The system offers seven layers with different colors. You can set technics for each 
layer, and the system regards objects with the same color as the same layer and 
sharing the same technics. 
You can do the following in the bar: 

o To set technics for the target layer, click the target layer. 
o To apply technics of one layer to the another one (target one), click the target 

layer, and select a choice from the drop-down box of Copy from XX. 
o To show all layers, set Show All to ON status. 

Otherwise, the system will only show layers in the current toolpath file. 
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2. Parameter setting bar 
You can switch between the following pages in the bar: 

o Film Cutting Param page: to set film cutting parameters for each layer. 
See Set Film Parameters for operation details and Film Cutting for parameter 
details. 

o Cut Param page: to set cutting parameters and special technics for each 
layer. 
See Set Cutting Parameters for operation details and Cutting Parameters for 
parameter details. 

o Piercing Param page: to set piercing parameters. 
See Set Piercing Parameters for operation details and Piercing for parameter 
details. 

3. Technic operation bar 
You can do the following in the bar: 

o Add technic remarks. 
o Open / save / save as technics. 

4. Unit setting bar 
It is used to set unit according to the actual situation. 

5.2 Operations 
The operations aim to set related parameters for the target layer. 

To do layer related operations, do the following in Layer Setting dialog box: 

1. Set film cutting parameters. 
2. Set cutting parameters. 
3. Set piercing parameters. 

After doing layer related operations, in the technic operation bar, do the following: 

1. Add technic remarks. 
2. Open / save / save as technics. 

5.2.1 Set Film Parameters 
It is used to solve the problem that the film on metal material is melted and stuck to the 
cutting head and the sheet during cutting coated metal material. 
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To set film parameters, do the following: 

1. To switch to Film Cutting Param page, in the parameter setting bar, click Film 
Cutting Param: 

 
2. Select a cutting type, and set related film cutting parameters. 

See Film Cutting Parameters for parameter details. 
3. Optional: To do film cutting at the fixed height (determined by common parameter 

Fixed Height), check Fixed Film Cutting. 
4. Optional: To turn on the gas during / after film cutting, check Gas ON after Film 

Cutting. 

5.2.2 Set Cutting Parameters 
It is used to do the following: 

 Set cutting parameters. 

 Set special technics. 

 Edit the power curve. 
Used to make the cutting power and frequency change with the cutting speed 
accordingly and make sure thermal power absorbed in unit area is the same and 
achieve fine cutting result, so as to solve problems like over-burning around the 
corner and different cutting results in terms of thickness. 
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To set cutting parameters, do the following: 

1. To switch to Cut Param page, in the parameter setting bar, click Cut Param: 

 
2. Set parameters in Cut Param area and Special Technic area. 

See Cutting Parameters for details. 
3. To adjust speed power and speed frequency, check Adjust Speed Power and 

Adjust Speed Frequency in Power Curve area. The system makes the cutting 
power and cutting frequency change with the cutting speed during cutting. 
Otherwise, the cutting power and cutting frequency will keep the same all the time 
during cutting. 
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4. Taking checking Enable Speed Power Adjust as an example, to open Speed 
Power Curve Editing dialog box, click Edit. 

 
5. To modify the node, do one of the following: 

o On the curve, to add a node, double click the target position, or to delete a 
node, double click the target node. The corresponding speed and power 
nodes are added / deleted in the right list synchronously. 
The more the added nodes, the more accurate the curve. 

o In the list, to add a group of speed and power nodes, click Add, and double 
click to modify the values, or to delete a group of speed and power nodes, 
select the values and click Delete. The corresponding speed and power 
nodes are added/deleted on the left curve synchronously. 
Note: The curve is an increasing curve. Thus, the added value should be 
greater than the previous values. And 0 / 100 cannot be modified. 

If you need to restore the curve to the default, click Clear. 
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5.2.3 Set Piercing Parameters 
To set piercing parameters, do the following: 

1. To switch to Piercing Param page, in the parameter setting bar, click Piercing 
Param: 

 
2. Select a piercing method. 

See Piercing Methods for details. 
3. Set piercing related parameters. 

See Piercing Parameters for details. 
4. Optional: If parameter Pierce Mode is set to Gradual, set parameter Increment S. 

The cutting head will fall to the cutting head at the set increment speed. Otherwise, 
it will follow to the cutting head. 

5. Optional: To make the system turn off the later and execute blowing after piercing, 
set Extra Blow to ON status, select a gas type in the drop-down box of Laser off 
Blow Gas, and set parameters Laser off Blow Press. and Laser off Blow Delay. 
Otherwise, the system will execute blowing with the laser on after piercing. 

5.2.4 Add Technic Remarks 
It is used to set technic remarks, and it is convenient to automatically generate the name 
of a technic file during saving or saving as the technic file. 

Naming rule: Laser power - Material - Thickness - Machining type - Cutting gas - Nozzle 
type - Aperture 
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To add technic remarks, do the following: 

1. To open Set Technic Remark dialog box, in the technic operation bar, click the 
blue characters after character TechnicRemark: 

 
2. Set the material type, thickness, laser power, machining type, nozzle type and 

nozzle aperture. 
3. Add remarks. 

5.2.5 Open / Save / Save as Technics 
It is used to open a technic file, save technics or save technics as the target path. 

Naming rule of technic files: Layer name - Material - Thickness - Laser power - Machining 
type - Nozzle type - Aperture - Cutting gas - Remark 

The format of technic files should be LTPX. 

To open / save / save as technics, in the technic operation area, do the following: 

 To open a technic file, click Open, and select the target technic file. The name of 
the technic file shows in the upper right corner of Layer Setting dialog box. 
The technic file will overwrite the original one if there already exists a technic file. 

 To save technics, click Save: 
o If the technic file is newly created, set related information and click Save in 

Save Technic As dialog box, select the target path and click Save. 
o If there already exists a technic file (technic name shows in the upper right 

corner), the technic file is updated. 

 To save the existed technic file to the target file path with the target file name, click 
Save As, set related information, click Save in Save Technic As dialog box, select 
the target path and click Save. 
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5.3 Explanation 

5.3.1 Film Cutting 

5.3.1.1 Types 
Film cutting includes the following types: 

 Single cut: to cut film for a single object before cutting the object, and then do the 
same for other single objects. 

 Group cut: to cut film for objects in the same group before cutting the group, and 
then do the same for other groups. 

 Global cut: to cut film for all objects before cutting them. 

5.3.1.2 Parameters 
Film cutting includes the following parameters: 

 Pre Laser On: the delay time before the laser is turned on. 

 Post Laser On: after the laser is turned on, the system lasts the set time before the 
next step. 

 Pre Laser Off: the delay time before the laser is turned off. 

 Speed: the cutting speed when feedrate override is 100%. 

 Gas Type: the auxiliary gas during cutting. 

 Pressure: the auxiliary gas pressure during cutting. It should be used together with 
the proportional valve. 

 Power: the laser intensity during cutting when the laser device is adjusted via the 
analog quantity. 

 Frequency: the carrier frequency of PWM modulate signals during cutting, namely 
the light output times in one second. The larger the value is, the longer light output 
time is. 

 Duty Ratio: in per unit pulse cycle, the ratio of light output time to the unit pulse 
cycle time. You can set it by adjusting the laser device via PWM during cutting. 

 Height: the distance between the nozzle and the material during cutting. 

 Focus: the position of focus during cutting. It takes effect after enabling focus 
control. 

 Lift Height: the uplifting distance of the cutting head after cutting each object. 

 Fixed Film Cutting: to do film cutting at a fixed height (determined by parameter 
Fixed Height). 

 Gas ON after Film Cutting: to turn on the gas during film cutting and after film 
cutting. 

5.3.2 Cutting Parameters 

5.3.2.1 Common Parameters 
The common parameters include the following: 

 Pre Laser Off: the delay time before the laser is turned off. 

 Pre Laser On: the delay time before the laser is turned on. 

 Post Laser On: after the laser is turned on, the system lasts the set time before the 
next step. 

 Speed: the cutting speed when feedrate override is 100%. 

 Power: the laser intensity during cutting when the laser device is adjusted via the 
analog quantity. 

 Frequency: the carrier frequency of PWM modulate signals during cutting, namely 
the light output times in one second. The larger the value is, the longer light output 
time is. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

84 / 119 

 Duty Ratio: in per unit pulse cycle, the ratio of light output time to the unit pulse 
cycle time. You can set it by adjusting the laser device via PWM during cutting. 

 Lift Height: the uplifting distance of the cutting head after cutting each object. 

 Prepierce Up H: the uplifting distance of the cutting head after piercing each hole 
during preliminary piercing. If the piercing times is set to 1, this parameter is invalid. 

 Gas Type: the auxiliary gas during cutting. 

 Pressure: the auxiliary gas pressure during cutting. It should be used together with 
the proportional valve. 

 Height: the distance between the nozzle and the material during cutting. 

 Focus: the position of focus during cutting. It takes effect after enabling focus 
control. 

5.3.2.2 Special Parameters 
The special parameters include the following: 

 Ignore This Layer: to ignore all objects in the current layer during cutting. 

 Gas Keeps on for This Layer: to keep the gas on during cutting all objects in the 
current layer. 

 Side Blow at Pierce: to open port Side Blow during piercing. 

 Side Blow at Cut: to open port Side Blow during cutting. 

 Fixed Cut: to cut material at a fixed height. 

 Film Cut: to do film cutting for metal material with film on the surface. 

 Gxx Acc Vary Time: the change time for X-axis and Y-axis resultant acceleration 
during cutting. With it unchecked, common parameter Axial AccVaryTime is valid. 

 Pre-piercing: to do piercing for all objects in the current layer in advance in the 
actual cutting. 

 Micro Joint at High Speed: at micro joint, the cutting head will continue to moving 
without decelerating and the laser on. 

 Slow Start: to make sure the cutting quality for thick plates. With it checked, the 
system cuts an aperture whose length is the set start distance at the start speed, so 
as to make the gas blow into the aperture and cut thick plates at normal speed. 

 Start Dist: the startup distance. 

 Start Speed: the startup speed. 

 Cool Delay: the blowing time at cooling point. 

 Cool Gas: the gas during blowing. 

 Nozzle: the nozzle type and nozzle diameter. 

5.3.3 Piercing 

5.3.3.1 Types 
Piercing includes the following types: 

 None 
The system automatically does the following: 

a. Turn on the height sensing unit and blowing. 
b. Control the cutting head following to the cutting height, and wait for the delay 

time for blowing. 
c. Turn on the laser and start cutting. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

85 / 119 

 1st segment piercing / 2nd segment piercing 
The system automatically does the following: 

a. Turn on the height sensing unit and blowing. 
b. Control the cutting head following to the cutting height, and wait for the delay 

time for blowing. 
c. Turn on the laser and execute piercing for the delay time for piercing. 
d. According to the set piercing mode, do one of the following: 

 Segment: after controlling the cutting head falling to the cutting height 
without the laser on, turn on the laser and start cutting. 

 Gradual: Keep the laser on, control the cutting head falling to the 
cutting height at increment speed and start cutting. 

5.3.3.2 Parameters 
Piercing parameters include the following: 

 Increment S: the speed of the cutting head during falling from the piercing height to 
the cutting height during increment piercing. 

 Peak Power: the laser intensity during cutting when the laser device is adjusted via 
the analog quantity. 

 Frequency: the carrier frequency of PWM modulate signals during piercing. In 
general, it is set relatively lower, and pulse is used to avoid bad piercing. 

 Duty Ratio: in per unit pulse cycle, the ratio of light output time to the unit pulse 
cycle time. You can set it by adjusting the laser device via PWM during piercing. 

 Gas: the auxiliary gas during piercing. 

 Pressure: the auxiliary gas pressure during piercing. It should be used together 
with the proportional valve. 

 Height: the distance between the piercing position and the material. 

 Focus: the position of focus during piercing. It takes effect after enabling focus 
control. 

 Delay: the duration of the laser on at piercing height during gradual piercing and 
segment piercing. 

 Extra Blow: to execute blowing with the laser off after piercing. 

 Laser off Blow Gas: the blowing gas, including air, nitrogen and oxygen. 

 Laser off Blow Press.: the pressure during blowing. 

 Laser off blow Delay: the interval for executing blowing after turning off the laser. 
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6 Nesting 
6.1 Overview 
During batch machining, to improve sheet utilization and machining efficiency, you can 
nest parts on the sheet and nest circular holes in advertisement words. 

Based on the principle of part nesting priority and material utility maximization, nesting can 
achieve the following: 

 Nest a kind of parts or several kinds of parts. 

 Nest a kind of parts over the whole sheet. 

 Preview nesting effects and analyze nesting results. 

 Fill circular holes in advertisement words. 

6.2 Operations 
Before nesting toolpaths, make sure one of the following: 

 You have plugged the dongle into the USB interface of your host. 

 You have imported an authorized file. 
To do nesting, select one of the following: 

 Nest parts. 

 Fill circles on advertisement words. 

6.2.1 Nesting Parts 
To nest parts, select one of the following: 

 Nest parts in the toolpath: to nest parts in the current toolpath, including setting part 
number, remnant type, rotation angle, etc. 

 Set one-key nesting: to nest the selected objects with one click. A shortcut for 
nesting without separately editing parts. 

 Bestrew objects: to generate the copies of selected object and nest them on a 
sheet. 
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6.2.1.1 Nest Parts in the Toolpath 
Before nesting parts in the toolpath, make sure the target parts and sheet are closed 
objects. 

To nest parts in the toolpath, do the following: 

1. To add parts or sheets, do one of the following: 
o To directly import a part or sheet file, do one of the following, and select a 

DXF / DWG file in the target file path: 

 Click  Nest in the common toolbar, and click  Import → Import 
Part / Import Plate in Nest: Parts / Nest: Plates / Nest Result dialog 
box. 

 In the menu bar, click Nest → Import Part / Import Plate. 
o To directly add drawn parts or sheets in the drawing window, select the 

target objects, do one of the following, and modify part/sheet number: 
 Right click, select Add to Part List / Add to Plate List. 
 In the menu bar, click Nest → Add to Part List / Add to Plate List in 

the menu bar. 

 
To show the added parts or sheets on the drawing window, double click the parts or 
sheets in Nest: Parts / Nest: Plates / Nest Result dialog box. 
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2. Optional: To select the target part(s) or sheet(s) for nesting, check the checkbox in 
front of the target part(s) or sheet(s). 
Otherwise, all parts / sheets in the nesting list will be nested. 

3. To open Nest dialog box, select one of the following: 

o In the common toolbar, click the drop-down box of  Nest. 

o In the common toolbar, click the drop-down box of  Nest → Nest. 
o In the menu bar, click Nest → Do Nesting. 

 
4. In Part Selection area, select nesting all parts or checked parts. 
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5. In Nest Parameters area, do the following: 
a. Set the following parameters: 

 Plate Margin: the distance between parts and the edge of sheet. 
 Part Space: the distance between parts. 
 Rotation Angle: the rotation angle of parts. 
 Start Pos: the position to start nesting. 
 Direction: the nesting direction, including vertical direction and 

horizontal direction. 
b. To choose nesting by efficiency or utilization, slide the slider 

Efficiency/Utilization. 
c. Optional: To nest a single part to the inner hole of the nested objects, check 

Nesting in Part Hole. 
The inner hole belongs to the waste area. 

d. Optional: To share an edge, check Common Edge and select one of the 
following strategies: 

 All 
 Only Lines: the line edges share an edge and the curve edges do not 

share an edge. 
With this strategy, please set parameter Min Length. The line whose 
length is less than the set value does not share an edge with other 
lines. 

See Share an Edge for details. 
6. To save material to the maximum extent, in Remnant area, check Generate 

Remnant, and select a remnant type (Rectangle, type T, type L). 
7. Click OK. 
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The system automatically nests toolpaths and shows the nesting result in the drawing 
window: 

 

To edit objects, edit them on the drawing window. 
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6.2.1.2 Set One-key Nesting 
To set one-key nesting, select the target objects, do the following: 

1. To open One Key Nest dialog box, select one of the following: 

o In the common toolbar, click the drop-down box of  Nest → One Key 
Nest. 

o In the menu bar, click Nest → One Key Nesting. 

 
2. In Plate Param area, set parameters Plate Length and Plate Width according to 

the actual situation. 
3. In Nest Param area, do the following: 

a. Set the following parameters: 
 Part Distance: the distance between parts and the edge of sheet. 
 Plate Edge: the distance between parts. 

b. Select a rotation strategy, and set parameter Rotation Angle. 
c. To set the position to start nesting, select from the drop-down box of Start 

Pos. 
d. To set the nesting direction (including vertical direction and horizontal 

direction), select from the drop-down box of Direction. 
e. To choose nesting by efficiency or utilization, slide the slider 

Efficiency/Utilization. 
f. Optional: To nest a single part to the inner hole of the nest objects, check 

Nesting in Part Hole. 
The inner hole belongs to the waste area. 

4. Click OK. 
The system automatically nests toolpaths and shows the nesting result on the drawing 
window. 
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6.2.1.3 Bestrew Objects 
To bestrew objects, select a single object, and do the following: 

1. To open Bestrew Nest dialog box, select one of the following: 

o In the common toolbar, click the drop-down box of  Nest, and select 
Bestrew Nest. 

o In the menu bar, click Nest → Bestrew Nest. 

 
2. In Plate Param area, set parameters Plate Length and Plate Width. 
3. In Nest Param area, do the following: 

a. Set the following parameters: 
 Part Distance: the distance between parts and the edge of sheet. 
 Plate Edge: the distance between parts. 

b. Select a rotation strategy. 
4. Click OK. 

The system automatically nests toolpaths and shows the nesting result on the drawing 
window. 

To edit objects, edit them in the drawing window. 

6.2.2 Fill Circles on Advertising Words 
It is used to fill the objects on the advertising board with circles. 

It includes the following: 

 Fill objects with circles. 

 Check the circle quantity. 

 Adjust circles. 

 Erase circles. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

93 / 119 

6.2.2.1 Fill Objects with Circles 
It is used to arrange circles evenly in the objects. 

To fill objects with circles, do the following: 

1. To open Circle Fill dialog box, in the menu bar, click Nest → Advertise Words Fill 
→ Circle Fill: 

 
2. Do one of the following: 

o To manually fill the object with circles, set parameters in Public Param area, 
click Manual Fill, and click the target position on the drawing window. The 
system automatically generates a circle as follows: 

 
Note: The blue circles are circles that have been added, the small black 
circle is the circle to be added and the big black circle is automatically 
generated for helping you to know the circle space. 
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o To automatically fill the object with circles, do the following: 
i. Select a filling strategy: 

 Well-Distributed: to well distribute circles in the object so as to 
effectively reduce circles. It is appropriate for the irregular fonts. 

 Ring: to fill circles on generated contour lines so as to orderly 
arrange filled circles on the contour of the target object and 
effectively draw contour of object. 

 Rectangle: to fill circles with equal intervals, so as to keep 
intervals between adjacent circles are the same. It is 
appropriate for founder fonts. 

 Edge: to arrange circles on the edge. It is appropriate for thin 
fonts. 

 Horizontal: to arrange circles on the line that is parallel with X-
axis, so as to make circle centers of each row are on the same 
horizontal line. It is appropriate for founder fonts. 

 Vertical: to arrange circles on the line that is parallel with Y-
axis, so as to make circle centers of each row are on the same 
vertical line. It is appropriate for founder fonts. 

ii. Set related parameters in Public Param and Strategy Param areas. 
iii. Click Auto Fill. 

6.2.2.2 Check the Circle Quantity 
It is used to check statistics of circles, including their quantities and diameters. 

To check the circle quantity, do the following: 

1. In the menu bar, click Nest → Advertise Words Fill → Circle Check. 
2. Select the target region. 

The result shows in Circle Num Check dialog box: 
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6.2.2.3 Adjust Circles 
It is used to change the distribution of certain circles, so as to solve the problem that the 
circles cannot be filled in certain regions or its filling effect is not good. 

To adjust circles, do the following: 

1. In the menu bar, click Nest → Advertise Words Fill → Circle Adjust. 
2. Set parameters Edge Distance and Circle Distance. 
3. Select the target region. 

The system automatically deletes circles in the target region and distributes circles with 
filling strategy Rectangle. 

6.2.2.4 Erase Circles 
It is used to delete redundant circles in the objects. 

To erase circles, do the following: 

1. In the menu bar, click Nest → Advertise Words Fill → Circle Erase. 
2. Select the target region. 

The system automatically deletes circles in the target region. 

7 Common Operations 
7.1 Set the Laser Device 
It is used to set basic parameters, burst parameters and communication parameters 
according to the type of the laser device. 

The communication modes of each supported laser device is as follows: 
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COM √ √ √ × √ × × × × × × × 

Ethernet × √ √ × × √ √ × × × × × 

Board IO √ √ √ √ √ √ √ √ √ √ √ √ 
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To set the laser device, do the following: 

1. To open Laser Device Setting dialog box, in the menu bar, click Advanced → 
Laser Device Setting: 

 
2. To enable laser device setting, in the lower corner, check Manufacturer. 
3. In Basic Param area, set the following parameters: 

o Device Type 
o Max Power 
o Min Pulse Width 

4. In Burst Param area, set the following parameters: 
o Power 
o Frequency 
o Duty Ratio 
o Delay 

5. In Communication Param, select a communication mode. 
6. Optional: To clear the used time of the laser device, in Laser Device area, click 

Clear. 

7.2 Monitor the Laser Device 
It is used to check the status of the laser device, including power, temperature, water flow, 
mode, alarms, etc. 

Before monitoring the laser device, make sure the following: 

 The laser device works normally. 

 The communication of the software is normal. 
To monitor the laser device by its upper computer at the first time, do the following: 

1. In the menu bar, click Advanced → Laser Device Monitor. 
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2. Select the software of the upper computer in the target path. The software of the 
upper computer for the laser device starts. 
Note: After your first operation, the path will be automatically filled into parameter 
Laser Device Program Path. As a result, there is no need to select the path any 
more. 

7.3 Execute Y1-axis and Y2-axis Jiggle 
It is used to separately adjust Y1-axis and Y2-axis. You can adjust the feedback 
coordinates of Y1-axis and Y2-axis to the same according to the actual synchronous 
deviation. 

To execute Y1-axis and Y2-axis jiggle, do the following: 

1. To open Y1Y2 Jiggle dialog box, in the menu bar, click Machining → Y1Y2 Jiggle: 

 
2. Set Y1Y2 Jiggle to ON status. 
3. Select the step size (0.01mm / 0.1mm / 1mm) or click the input box and customize a 

step size. 
The customized step size is 5mm by default. 

4. To adjust the feedback coordinates of Y1-axis and Y2-axis, click Y1+ / Y1- / Y2+ / 
Y2-. 
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7.4 Check Statistics 
It is used to generate a statistic report to show the machining results, including the part 
number, cutting length, cutting time, piercing number, piercing time and machining costs. 

Before checking statistics, make sure the target toolpath file has been machined at least 
one time. 

To check statistics, do the following: 

1. To open Statistics Information, select one of the following: 
o In the running report bar, click Report. 
o In the menu bar, click Machining → Statistics Information. 

 
2. Check statistic information. 
3. To calculate the total costs of the target machining items, check the machining 

items, click Charge, input related prices, and click Calculate. 
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4. To show the statistics in a report, check the target machining items in Statistics 
Information dialog box, and click Report: 

 
The report can be exported as a PDF file. 
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7.5 Do a Burn Test 
It is used to make sure the motion stability of each axis, at the first commissioning for the 
machine tool. 

Before doing a burn test, make sure each axis has been returned to the machine origin. 

To do a burn test, do the following: 

1. To open Burn Test dialog box, in the menu bar, click Machining → Burn Test: 

 
2. Select the target axis, and set the start position, end position and speed at 1st, 2nd 

and 3rd stage for the burn test. 
3. Optional: To do burn test for the exchange workbench, check Enable Switch, and 

set the interval. 
4. Set the time at 1st, 2nd and 3rd stage for the burn test. 
5. Optional: To check the history records of burn tests, click History. 
6. Optional: Check Shield collision and cutting heads alarms. 

Warning: Risk of collision. Please check it with caution! 

7. Click Start. The system starts to do a burn test. 
During doing a burn test, to stop it, click Stop. 

7.6 Lubricate the Lead Screw and Guide Rail 
It is used to lubricate the lead screw and guide rail after the machine tool runs for a period 
of time, so as to improve wear resistance and transmission efficiency. 

To lubricate the lead screw and guide rail, do one of the following: 

 Automatically lubricate the lead screw and guide rail during machining according to 
the set parameters. 

 Manually lubricate the lead screw and guide rail. 
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7.6.1 Automatically Lubricate the Lead Screw and Guide Rail 
To automatically lubricate the lead screw and guide rail, do the following: 

1. In the menu bar, click System → System Parameters, find and set parameter 
Lube Type to a value except 0: 

o 0: None 
o 1: Auto lube (Time) 
o 2: Auto lube(Distance) 

2. Set the following parameters according to the set lube type: 
o Auto Lube Duration 
o Auto Lube Interval: please set the parameter when parameter Lube Type 

is set to 1. 
o Auto Lube Dist.: please set the parameter when parameter Lube Type is 

set to 2. 
After setting, the system automatically turns on lube for the set value of parameter Auto 
Lube Duration after the set interval / distance. 

7.6.2 Manually Lubricate the Lead Screw and Guide Rail 
To manually lubricate the lead screw and guide rail, do the following: 

1. To open Lubricate dialog box, in the menu bar, click Machining → Lubricate: 

 
2. Set the related parameters, and click Start. The system starts lubricating the lead 

screw and guide rail. 

7.7 Set a Fixed Point 
It is used to control the cutting head to return to the set point after machining. 

To set a fixed point, in the menu bar, click System → System Parameters and set the 
following parameters: 

 Fixed Point Position(X) 

 Fixed Point Position(Y) 
In the menu bar, click Machining → To Fixed Point. The cutting head automatically 
moves to the set fixed point. 

7.8 Detect the Encoder 
It is used to detect whether the encoder feedback matches with the rotation direction of the 
motor, and automatically calculate the feedback pulse count per resolution and the 
encoder direction. 
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Before detecting the encoder, make sure the following are set correctly: 

 Drive parameters 

 Pulse equivalent 

 Axis direction 

 Command pulse count Per revolution 
To detect the encoder, do the following: 

1. To make sure enough travel for detection, move X-axis and Y-axis to the middle of 
the travel. 

2. To open Encoder Detection dialog box, in the menu bar, click System → 
Hardware Diagnose → Encoder Detection: 

 
3. Optional: To automatically fill in the feedback result after detection, check 

Automatically write detection values after detection. 
4. Optional: In Setting area, set the moving distance for X-axis and Y-axis. 

Default distance is 10mm. But it is usually set as the length of a pitch to minimize 
the detection error. 

5. In Control Panel area, click Start. 

7.9 Enable Automatic Exhaust 
It is used to automatically exhaust smoke by fans installed below the machine tool, so as 
to avoid a large amount of smoke during laser cutting. 

To enable automatic exhaust, in the menu bar, under manufacturer permission, click 
System → System Parameters → External Device → Exhaust, find parameter Enable 
Auto Exhaust and set it to Yes. 
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7.10 Set a Mark Point 
It is used to set the machine coordinate of the target position as that of a mark point, so as 
to control the cutting head to return to the mark point as needed. 

Before setting a mark point, make sure the system has returned to the machine origin. 

To set a mark point, do the following: 

1. To open Mark Point dialog box, do one of the following: 

o In the drawing toolbar, click  Mark Point. 
o In the menu bar, click Machining → Mark Point. 

 
2. To move the cutting head to the target position, in the machine control bar, click 

axis button ↑ / ↓ / ← / →. 
3. In the drop-down box, select a mark point, and click Mark. 

There are 8 mark points at most. 
4. Optional: To show all marked points in the drawing window, click Show All. 
5. Optional: To show the marked point after closing Mark Point dialog box, check 

Display the mark point after interface closes. 
6. In the drop-down box, select the target mark point, and click To Mark Point. The 

cutting head automatically returns to the mark point. 
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7.11 Set Nozzle Cleaning 
Before setting nozzle cleaning, make sure the following: 

 Parameter Use Different Position of Axis is set to Yes. 

 The system has returned to the machine origin. 
To set nozzle cleaning, do the following: 

1. To open Clean dialog box, select one of the following: 

o In the machine control bar, click . 
o In the menu bar, click Machining → Auto Clean Nozzle. 

 
2. Select a gas type, and set the pressure, cleaning times, speed of the cutting head 

during cleaning. 
3. To get the start point and end point for cleaning, do one of the following: 

o Set parameters Start: X / Y and End: X / Y separately. 
o Move the cutting head to the target position, and click Get Start Point / Get 

End Point. 
4. To get Z-axis height for cleaning, do one of the following: 

o Set parameter Z Location: Z. 
o Move the cutting head to the target position, and click Get Height. 

If two heights are needed, please set system parameter Use Different Position of 
Axis to Yes. 
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8 System Management 
8.1 Generate an Installation Package 
It is used to create a complete installation package on the basis of current system data, 
which is useful to back up system files and save a stable version of the system. 

To generate an installation package, do one of the following: 

1. In the menu bar, click File → Generate Installation Package. Packup Tool dialog 
box pops up. 

2. Modify the name and storage path of the installation package. 
3. Optional: Click Advanced, and set the following advanced settings: 

 
o Language: at present, the system supports Chinese and English. 
o Parameter migration 

 Keep All Local Parameters 
 Keep Only Machine-Specific Parameters 
 Fresh Installation: Keep no parameters. 

o Auto boot: whether to automatically start the software once the machine 
boots. 

o Support language selection: whether to support switching the current 
language. 

o Create a desktop shortcut: whether to create a shortcut on the desktop. 
o Start the software after installation: whether to automatically start the 

software after installation. 
4. Click Pack up. The system starts to generate the installation package. 

After finishing, find the generated installation package under the set path. 
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8.2 Back up and Restore Parameters 
It is used to back up parameters by saving them as a ZIP file for later use and restore the 
backup parameters, so as to avoid repeated setting. 

To back up and restore parameters, do the following: 

1. To open Back up and Restore Parameter dialog box, in the menu bar, click 
System → Back up and Restore Parameter: 

 
2. Select one of the following: 

o To back up parameters as a ZIP file, select the target file and click Back up. 
o To restore parameter settings to the previously backup settings, click 

Restore and restart the software to make it effective. 
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8.3 Set Common Parameters 
It is used to set frequently used parameters, including machine parameters, gas 
parameters, burst parameters, following-up parameters, scouring parameters, set user 
habits and switch units. 

To set common parameters, do the following: 

1. To open Common Parameters dialog box, select one of the following: 

o In the common toolbar, click  CommonParam. 
o In the menu bar, click System → Common Parameters. 
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2. Set the following machine parameters in Machine Param area: 
o Frame Check Speed: the speed for framing cutting. Range: 0mm~60000. 
o G00 Speed: the G00 speed of each axis during machining. Range: 

1mm~100000mm. 
o G00 AccVaryTime: the change time of G00 acceleration for a single axis. 

Range: 1mm~10000mm. 
o Max.Acc at Corners: the maximum acceleration of the adjacent axes. It is 

recommended to set it as 1~2 times of the maximum acceleration. Range: 
0.1mm~50000mm. 

o G00 Acc: the maximum acceleration during G00 motion. Range: 
0.001mm~50000mm. 

o Cutting Acc: the resultant acceleration in accelerating phrase during 
machining. Range: 0.1mm~50000mm. 

o Axial AccVaryTime: the change time of acceleration for a single axis during 
machining. 

o Max.S of RefCircle: the maximum speed for a reference circle with diameter 
10mm. Range: 1mm~1000000mm. 

Set the following user habits in User Habits area: 

 To do piercing at resume, check Do piercing at resume. 

 To automatically divide the objects with nested relation into the same group for pre-
piercing, check Auto group prepunch. 

 To define X-axis and Y-axis action after machining, select in the drop-down box of 
Action after End. 
Including no action, returning to the mark point, fixed point and workpiece origin. 

1. Select the default gas type and set gas parameters in Gas Param area: 
o Gas Change Delay: mainly used for gradual piercing and segment piercing. 

If the gas for cutting is different from the gas for piercing, during the delay 
time for gas switching after piercing, laser will keep on. 

o 1st Point BlowDelay: the delay time for blowing after the start of machining 
or breakpoint resume. 

o Blow Delay: the delay time for turn on blowing. 
o P. in Idle: the gas pressure for manual blowing in idle status. 
o Gas ON Distance: the maximum distance used for switch between two 

objects with the laser on. 
2. Set the following burst parameters in Burst Param area: 

o Power: the laser intensity during burst. 
o Frequency: the carrier frequency of PWM modulate signals during burst. 
o Duty Ratio: in per unit pulse cycle, the ratio of light output time to the unit 

pulse cycle time during burst. 
o Delay: the duration for the laser on during burst. 
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3. Decide whether to enable leapfrog and set the following parameters in Follow area: 
o Leaping Min Dis: if the actual distance is less than the set value, leapfrog 

will not occur and the cutting head will traverse to the start point of next 
object without lifting. 

o Follow Max H.: if the cutting height / piercing height is less than the set 
value, the cutting head will follow to the set height. Otherwise, it will follow to 
1mm position and lift to the set height. 

o Z UP Pos: the machine coordinate of Z-axis after turning off the height 
sensing unit after returning to the machine origin, or after machining ends. 

o Fixed Height: to fix Z-axis at the fixed height. During cutting at the fixed 
height, the height sensing unit will not turn on. 
You can directly set its value or move the cutting head to the target position 
and click Get Fixed Pos. 

4. Optional: To blow for cleaning the nozzle before cutting and make sure abundant 
gas in the channel for better cutting quality, enable scouring by gas and set the 
following parameters in Scour by Gas area: 

o Gas Pressure: the percent of gas pressure for scouring. 
o Duration: the duration for each scouring. 
o Interval: the interval between each scouring when the scouring times is 

greater than 1. 
o Times before Start: the scouring times when cutting starts. 
o Times in Resume: the scouring times during breakpoint resume. 

5. Switch the unit of speed, acceleration, time or gas pressure in Unit switch area. 
To switch to system parameters, click System Param at the bottom. 

8.4 Switch the System Language 
At present, the system supports Chinese and English. 

To switch the system language, in the menu bar, click System → Language, and select 
the target language. 

Restart the software to make the setting effective. 

8.5 Check System Logs 
It is used to check different types of system logs and it is good for troubleshooting. 

Once the log file exceeds 20M, the system will automatically generate a backup log file 
named NcStudio_xxxx.log under User folder and delete the original one. 
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To check system logs, do the following: 

1. To open Log dialog box, do one of the following: 
o In the alarm/system info bar, double click Alarm / System. 
o In the menu bar, click System → Log. 

 
2. Check different types of system logs for troubleshooting: 

o To check logs about running status, click Show Info. Logs with icon  show 
in the dialog box. 

o To check alarm logs, click Show Alarms. Logs with icon  show in the 
dialog box. 

o To check error logs, click Show Errors. Logs with icon  show in the dialog 
box. 

o To check all logs when the system starts, click All Logs. 
o To check logs in the past since installation, click Query History. 

3. Optional: To delete all logs, click Clear. 
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8.6 Count Machining 
It is used to calculate the total number of machining. 

To count machining, do the following: 

1. To open Count Setting dialog box, in the statistics bar, click Count Setting: 

 
2. Check Enable Counting, set parameters Planned Count and Finished Count 

according to your needs, and select the actions after end. 
3. Optional: Check Automatically clear the finished count after file name 

changes. 
The system automatically counts machining as follows: 

 If a toolpath file is machined without any interruption, the number of machining adds 
1. 

 If machining is interrupted, the number of machining adds 1 after executing 
breakpoint resume and finishing machining. 

 After a new file is imported or the file name is changed, the number of machining 
turns to zero. 
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8.7 Set Cycle Machining 
It is used to set times and interval for cycle machining and check the finished times. 

Cycle machining is available to both normal machining and dry run. 

To set cycle machining, do the following: 

1. To open Cycle Machining dialog box, in the menu bar, click Advanced → Cycle 
Machining: 

 
2. Check Enable, and set parameters Times and Interval. 

The system automatically counts the finished times as follows and fills in the result into 
Finished input box: 

 If you pause / stop machining before reaching the set cycle times, the finished times 
is the actual finished cycle times at present. 

 If a toolpath file is machined completely, the finished cycle times adds 1. 
To clear the current finished times after finishing the set cycle times, click Clear. 

8.8 Register the Software 
It is used to restrict the system usage time. 

Before registering the software, make sure the machine tool is in idle or E-stop status. 

To register the software, do the following: 

1. Get a registration code. 
2. Register the software with a registration code. 

After registering the software, check the remaining registration time in NcStudio dialog 
box. 

8.8.1 Get a Registration Code 
Before getting a registration code, do the following: 

1. To get an account, do one of the following: 
o Contact local sales. 
o Dial 400-882-9188. 

2. Fill in Registration Information Confirmation Letter and send it to Weihong Company 
after sealing it. 
Weihong Company will put the information on file. 
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To get a registration code, do the following: 

1. To open NcStudio dialog box, in the menu bar, click Help → About: 

 
2. Record the device number. 

The last three digits of the device number vary with the registration times: 

Registration Times Last Three Digits 

0 000 

1 001 

... ... 

3. To enter into WEIHONG official account in WeChat, scan the QR code on the lower 
left. 

4. To get a temporary password, click Service → Register, fill in the blanks and click 
Activate Account. 
Note: The temporary password will be sent to the registered mobile phone. 
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5. Return to Log in page, fill in the blanks, enter the temporary password, and fill in 
related information in Time Registration page: 

 

To reset the password, click . 
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8.8.2 Register the Software with a Registration Code 
To register the software with a registration code, do the following: 

1. To open NcStudio dialog box, in the menu bar, click Help → About. 
2. Click Register. Register dialog box pops up: 

 
3. Enter the registration code in Register code input box. 

Restart the software to make registering effective. 

If the software expired, a prompt The software is overdue. Please register! pops up 
after the software is started. At this time, please register the software again. 

If the motion control card and the software do not match, a prompt Board class error. 
Please register! pops up. At this time, please contact the manufacturer. 

8.9 Generate a Production Report 
It is used to check statistical information and the machining costs before machining. The 
information includes piercing number, the machining length, the machining time and the 
machining cost. 

To generate a production report, do the following: 

1. Optional: In the machining control bar, check Cut Selected and select the target 
objects. 
Otherwise, the system will help you check the statistical information of all objects. 

2. In the menu bar, click Machining → Production Report and check the production 
report. 
You can export the report as a PDF file format for printing. 

8.10 Log in the Camera 
It is used to monitor the machining condition and control machining. 

Before logging in the camera, make sure the following: 

 The camera has been installed. 

 You have got the login information. 
To log in the camera, do the following: 

1. In the menu bar, click System → System Parameters → External Device → 
Monitoring, and set parameter Enable Camera to Yes. The monitoring area of the 
camera shows in the top area of the main interface. 
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2. In monitoring area, right click and select Login. Log in dialog box pops up: 

 
3. Select a camera type, and input IP address, port number, user name and password. 

After logging in the camera, the machining condition shows in the monitoring area. 

If the camera is changed, right click in the monitoring area, select Logout and log in the 
camera again. 
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9 Shortcut Keys 
The shortcut keys for ease of operation is as follows: 
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Legal Notices 
The term “Software Product” includes all copies of the licensed software and its 
documentation. This license agreement is a legal agreement between You (either an 
individual, a legal entity or any affiliated companies or other entities) and Weihong 
Electronic Technology Co., Ltd. (hereinafter referred to as Weihong Company). By 
installing, copying, or otherwise using the Software Product, you agree to be bound by the 
terms and conditions of this license. Unless otherwise stated in this agreement, you shall 
not use, copy, revise, rent, or transfer the Software Product or any part of the Software 
Product for any other purposes. 

Requirements of Use 
1. You may install for use one copy of the Software Product on a single machine; 
2. You may make a copy of the Software Product for archive or backup purposes and 

the copy is to be used on this machine only; 
3. You may transfer the Software Product and the license agreement to a third party, 

provided that the third party accepts the terms and conditions stated in this 
agreement, with prior express permission from Weihong Company; 

4. When transfer confirmed, you shall transfer all the copies of the original documents 
and the supplementary documents to the third party or destroy all the copies un-
transferred; 

5. You can use the Software Product on a network server or intranet server only if it is 
stipulated in explicit terms that you are allowed to use the Software Product on a 
network server or intranet server, or you have purchased license for each node and 
terminal using the Software Product; 

6. You may NOT sublicense, assign or transfer the license agreement; 
7. You may NOT or direct any third party to reverse engineer, decompile or 

disassemble the Software Product; 
8. You may NOT copy or transfer the Software Product or any part of the Software 

Product unless otherwise expressly stated in this agreement; 
9. The license agreement shall be terminated automatically upon you transfer the 

Software Product or copies of all or part of the Software Product to a third party. 

Intellectual Property Rights Notice: 
The Software Product and all intellectual property rights therein (including but not limited to 
any all copyrights, patents, trademarks, and publicity rights) are owned by Weihong 
Company. The Software Product is protected for Weihong Company on the basis of 
Chinese copyright law and international treaty provisions as well as on the basis of other 
laws and agreements regarding intellectual property. You are not allowed to remove the 
copyright statement made in the Software Product, and guarantee that you shall copy the 
copyright statement in all copies of the Software Product or of any part of the Software 
Product. You are obliged to stop any form of illegal copying of the Software Product and 
accompanying materials. 

Weihong Company can update the Software Product at any time. You can pay real-time 
attention to Weihong Company's official website. 
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Termination: 
This license may be terminated by Weihong Company at any time once you violate any 
terms or conditions made in this agreement. Once the license is terminated, you are 
obliged to destroy all the copies of the Software Product or return them to Weihong 
Company. 

Now, we affirm that you have already read through this agreement and understood it 
thoroughly and agreed to comply with all of the terms and conditions of this agreement 
strictly. 

 

Weihong Electronic Technology Co., Ltd. 

 



Shanghai Weihong Electronic Technology Co., Ltd.

Address: No. 1590, Huhang Rd., Fengxian, Shanghai, China, 201401

Hot-line: 400 882 9188 

Website: www.weihong.com.cn/en
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